0

I have fresh-installed Ubuntu 14.04 over the weekend on my Dell E6520. The nouveau driver didn't allow me to use maximum resolution for my laptop display. Switching to the nvidia (proprietary, tested) driver solved that issue. However, my external display (Dell P2412H) shows up as 'Unknown display' in 'Displays' and allows maximum resolution of 1360 x 768 (should be 1920 x 1080). Switching back to nouveau doesn't help with either display.

$ xrandr
Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 16384 x 16384
VGA-0 connected 1360x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768       60.0 +
1360x768       60.0*    59.8  
1152x864       60.0  
800x600        72.2     60.3     56.2  
680x384        60.0     59.8  
640x480        59.9  
512x384        60.0  
400x300        72.2  
320x240        60.1  
LVDS-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080      59.9*+   39.9  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
1920x1080_60.00 (0x2d0)  172.8MHz
    h: width  1920 start 2040 end 2248 total 2576 skew    0 clock   67.1KHz
    v: height 1080 start 1081 end 1084 total 1118           clock   60.0Hz

I tried to force the new resolution via randr, but without much luck:

 gtf 1920 1080 60

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

:~$ xrandr --newmode "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
:~$ xrandr --addmode VGA-0 "1920x1080_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  140 (RANDR)
Minor opcode of failed request:  18 (RRAddOutputMode)
Serial number of failed request:  37
Current serial number in output stream:  38

Just in this is of importance, here's some info from glx:

:~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: NVS 4200M/PCIe/SSE2
GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 

EDIT: Just to get that out of the way: I have reconnected the cable multiple times. VGA is the only option right now - the laptop has VGA and HDMI outputs, the display has VGA and DVI inputs.

0

According to DELL specs, if you have an nvidia card on this computer, this must be an optimus laptop (hybrid graphics).

See "Tech specs" tab : http://www.dell.com/us/business/p/latitude-e6530/pd

On this computer, you can disable optimus in the bios. This is the recommended way to avoid multi-graphic cards problem on GNU/Linux, and thankfully this is possible on this computer model.

See : http://ubuntuforums.org/showthread.php?t=1726575 (you have a screenshot of the bios to see how to do it)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.