0

I had to setup a new workstation at work today, but couldn't get connected to the internet before looking at and following the other computer's in the office DNS settings as follows: Use 8.8.8.8, instead of automatic assignment setting.

Other IPv4 settings: "Obtain IP address automatically"

I briefly checked out our router's settings and it's configured as a DHCP server. The only DNS settings I could find that were configurable were Dynamic DNS, which is disabled. In the router's WAN IPv4 overview section it lists both WAN1 and WAN2 with addresses for IP Address, Default Gateway, and DNS.

I'm curious about what this DNS address is, and whether routers normally need to be configured somehow if you want to obtain DNS server addresses automatically.

Router: Cisco (Small Business) RV016 10/100 16-Port VPN Router

0

It can be a bit confusing. The router's DNS setting sets where the router goes to perform queries (this is usually an internal DNS server). There's also a DNS setting in the DHCP section, which is what the router tells your workstations to use when using the "Obtain IP address automatically" setting.

All that said, an internal DNS is not absolutely required, if you can live without certain internal features (e.g., internal email servers usually also require an internal DNS server).

8.8.8.8 is the IP address for Google's free DNS service. Based on what you've provided, I can assume:

  • you have no internal e-mail or DNS server
  • most of your business is Internet or cloud based (e.g., employees use GMail or some other similar service)
  • for some reason, you don't want to use your ISP's DNS service (if you do, there should be a setting in the DHCP section)

Also, the Dynamic DNS should be left disabled. It's used when you want to advertise a server on your work's network when: 1) your external IP tends to change over time (e.g., you're paying for a residential connection) or 2) you want to avoid paying for a zone (e.g., you want to use one of the "free" services.

  • +1 I found the DNS settings in DHCP setup to both be 0.0.0.0. Not connecting makes sense, if this is the address automatically adopted I guess. Confusingly, whatever I change these settings to, the WAN1&2 summaries default to my ISP's primary address. I'll have to experiment when I get to work to see if changing the settings will allow automatic adoption at workstations. And, yes, you're assumptions are correct, but I'm not sure why the previous Admin would have setup public DNS. Any ideas? – Kevin Jul 5 '14 at 17:33
0

Based on your description, it appears there is one of two problems:

  1. The DHCP server is not configured to provide a DNS server or servers when providing IP addresses.
  2. The IP address(es) provided by the DHCP server is not actually configured as a DNS server or is not working properly.

Since the other computers in the office seem to be using 8.8.8.8, the easiest way to address this may be to adjust the DHCP zone to provide 8.8.8.8 as the DNS server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.