my keyboard is damaged, the keyboard key [é] is always pressed and it prevents me from working. On windows I found the software sharpkey to disable the [é] button but on Ubuntu I can't found no solution. On many forums they talks about Xmodmap but I can not work on the terminal as the [é] button is often PRESSED. Please could you give me a solution for that issue. Thanks

  • 4
    Do you have ssh enabled? You could use xmodmap from another machine. But have you tried removing the key physically and cleaning under it?
    – Paul
    Jul 2, 2014 at 0:57

4 Answers 4


What I would try:

  1. Connect a USB keyboard in there, or get into the machine using ssh.

  2. Open a terminal, and run xev -event keyboard. It will show some stuff on screen. If you omit the arguments, you will notice that it will show some more stuff if you move your mouse, as well.

  3. Then, press the key combination you want to disable [é]. The info in the screen will change, and you will have to look for the keycode value.

  4. Run something like this, changing <value> for the value you got for the keycode in the last step:

    xmodmap -e 'keycode <value>='

    For example, if I want to disable the ~ key ( Shift + ` ), I would have to run:

    xmodmap -e 'keycode 49='

I have only tried this with more standard keys, like Caps Lock... but I guess it should work with this as well. I hope this helps!

  • 3
    But this works only under Xorg. Is it possible to disable on a tty too? Dec 31, 2016 at 0:03
  • 2
    It worked. What if I want to undo this?
    – Vagabond
    Jan 25, 2017 at 14:43
  • 1
    It didn't work for me with esc key, however xmodmap -e 'keycode <value>=NoSymbol' worked Sep 27, 2017 at 11:12
  • what about doing the same in terminal (/dev/vty*) w/o (or before starting) X ?
    – user373230
    Dec 17, 2017 at 18:21
  • How to make this work every time xorg starts? So after logout/login and reboot it keeps on working?
    – sscarduzio
    Mar 13, 2020 at 12:18

A simple bash script for my personal use has been uploaded at https://github.com/anitaggu/ikbdop.

To disable internal keyboard of laptop,

./ikbdop.sh detach

To enable the keyboard again

./ikbdop.sh attach

A brief howto is also uploaded at YouTube


It simply looks good and simple using xmodmap -e 'keycode 117='

I use this to disable the page down key and it works. Why don't you try this once . Do it ..

  • How is this better than accepted answer?
    – Toto
    Apr 9 at 8:16

You can also change the keyboard for new one. It is possible to order a keyboard for your particular laptop on the net and it comes by post envelope somewhere from China.

You can also just disconnect you keyboard and use external USB one. It is easy to open your laptop and disconnect a little cable going from the keyboard to the motherboard.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.