1

I would like to install Mavericks in VirtualBox. I tried different solutions but I can’t get this work. First I downloaded Mavericks from the app store.

Then I converted the InstallESD.dmg to an ISO using the Disk Utility and then renaming the file. But when I tried to boot I get this error in VirtualBox:

Fatal: No bootable medium found! System halted

And happened the same when I created the ISO with this script

#!/bin/bash
ESD=$1
TMP=$2

if [ -z "$ESD" ] || [ -z "$TMP" ]; then
    echo usage: "'$0' /path/to/esd /path/to/tmpdir"
    exit 1
fi
if ! [ -e "$ESD" ]; then
    echo "file '$ESD' does not exist"
    exit 1
fi
if ! [ -e "$TMP" ]; then
    echo "dir '$TMP' does not exist"
    exit 1
fi

MPAPP=/Volumes/install_app
MPIMG=/Volumes/install_img
IMGSPARSE=$TMP/install.sparseimage
IMGDVD=$TMP/install.cdr

detach_all() {
  if [ -d "$MPAPP" ]; then hdiutil detach "$MPAPP"; fi
  if [ -d "$MPIMG" ]; then hdiutil detach "$MPIMG"; fi
}
exit_all() {
  echo +++ Command returned with error, aborting ...
  exit 2
}

trap detach_all EXIT
trap exit_all ERR

echo +++ Trying to unmount anything from previous run
detach_all

echo +++ Mount the installer image
hdiutil attach "$ESD" -noverify -nobrowse -readonly -mountpoint "$MPAPP"


echo +++ Convert the boot image to a sparse bundle
rm -f "$IMGSPARSE"
hdiutil convert "$MPAPP"/BaseSystem.dmg -format UDSP -o "$IMGSPARSE"


echo +++ Increase the sparse bundle capacity to accommodate the packages
hdiutil resize -size 8g "$IMGSPARSE"

echo +++ Mount the sparse bundle for package addition
hdiutil attach "$IMGSPARSE" -noverify -nobrowse -readwrite -mountpoint "$MPIMG"

echo +++ Remove Package link and replace with actual files
rm -f "$MPIMG"/System/Installation/Packages
cp -rp "$MPAPP"/Packages "$MPIMG"/System/Installation/

echo +++ Unmount the installer image
hdiutil detach "$MPAPP"

echo +++ Unmount the sparse bundle
hdiutil detach "$MPIMG"

echo +++ Resize the partition in the sparse bundle to remove any free space
hdiutil resize -sectors min "$IMGSPARSE"

echo +++ Convert the sparse bundle to ISO/CD master
rm -f "$IMGDVD"
hdiutil convert "$IMGSPARSE" -format UDTO -o "$IMGDVD"

echo +++ Remove the sparse bundle
rm "$IMGSPARSE"

echo "Done"
echo "Find your DVD at '$IMGDVD'"

I also created a booteable pen drive with the information here and I mounted it as a virtual disk. But again VirtualBox throws an error when I try to mount the image:

Failed to open the hard disk file /Users/username/Documents/usbdrive.vmdk.

Could not open the medium '/Users/username/Documents/usbdrive.vmdk'.

VD: error VERR_RESOURCE_BUSY opening image file '/Users/username/Documents/usbdrive.vmdk' (VERR_RESOURCE_BUSY).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Medium
Interface: IMedium {05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac}
Callee: IVirtualBox {fafa4e17-1ee2-4905-a10e-fe7c18bf5554}
Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)
  • 1
    This question appears to be off-topic because it is about installing OS X in a VM on non-Apple hardware, which is unsupported and against the EULA. – slhck Jul 2 '14 at 8:48
  • 4
    @slhck Please tell me if I am wrong, I own a Mac, and I would like to run inside Mavericks a vm with Mavericks. That is against the EULA?. I thougth that the problem was running the vm with osx not in osx. Thank you – agusgambina Jul 2 '14 at 13:19
  • 1
    You're right, this is the case where it's allowed. Sorry –reopened. – slhck Jul 2 '14 at 14:34
1

I think this is answered by Mark at:

https://apple.stackexchange.com/questions/106476/how-to-install-os-x-mavericks-in-virtualbox#

I normally would include a summary to external sites (but it's a StackExchange site).

protected by JakeGould Oct 30 '15 at 15:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.