I am running LibreOffice 4.1 on a PC and am using it to type Arabic. I have configured my keyboard as an Arabic (Egypt), Arabic (101) keyboard from the Windows 7 Control Panel. I have enabled complex text layout (CTL) and then changed the direction setting from LTR (CTRL+SHIFT+A) to RTL (CTRL+SHIFT+A) after adding the corresponding icons for these to my Formatting toolbar under Tools -> Customize... as described here: http://alefba.us/libreoffice-arabic-persian Since I am on a PC rather than on a Mac I had to use a different font setting, and I have tried Adobe Arabic and Arabic Typesetting and in each case the result is the same.

The problem is that when I type an alif-hamza أ (with Arabic input enabled type 'n') it displays fine but when I follow such alif-hamza with a damma ُ (with Arabic input enabled type SHIFT-'e'), such damma is chopped off by the header. If I repeat this on the following line the damma will still be chopped off. It is as though the text is taller than the vertical space allocated for the font. See below:

damma chopped off at top

then if I perform an action such as resizing the window slightly then the top portion of the damma which had been chopped off appears:

damma appears after resizing window

for completeness here are screenshots of my LibreOffice settings:

configuration window 1

configuration window 2

How can I get this to work properly so that I do not have to resize the window or perform a similar operation for the alif-hamza + damma to display properly, in a vertical amount of space which takes into account the damma as well, and not just the alif-hamza?



1 Answer 1


There seems to be a problem with the fonts being used when entering the damma over the aliph-hamza. To solve the problem use some other font such as the Windows fonts Simplified Arabic or Traditional Arabic or install and use the Sheherazade font http://scripts.sil.org/cms/scripts/page.php?item_id=Scheherazade

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .