1

My computer is running windows 8, and suddenly started running slowly. When I open the task manager, it tells me that the CPU is using 99% - sometimes the disk usages jumps up as well.

The strange thing is, when I use the task manager to find the application or process, which are taking all the CPU, it is just randomly selects an app that gets a high % of the CPU. If I close the app that takes a lot of CPU, it just gives another app a high amount of CPU usage.

But if I open almost anything on the computer, that specific application will be given a high CPU % - that counts for all apps, but not windows itself. I been monitoring the CPU temperature, but it is below 40 Celsius. I tried to scan the computer with McAfee, but it stalls at 51% at an element name “rootkit”

I’ve been researching a lot to solve the problem, but I can’t do it on my own :’(


Okay, so i got Ubuntu to work on the computer, and it's running fast and smoothly - the CPU usage is "okay"

I also removed "cryptinno" with mcafee, but the CPU usage is still high when using windows

  • 1
    Maybe you can download Ubuntu live CD/DVD and test your hardware there (so you won't need to install) with a different operating system. If you see the same behavior you can assume it's an issue in the hardware. – drk.com.ar Jul 2 '14 at 17:32
  • So I did as I was told, and it works fine with another OS - so it's not a hardware problem. What do I then do? – MagnusMga Jul 3 '14 at 10:03
  • If cleaning your system up (as suggested in other replies) doesn't work you better install Windows over. Rootkits are really difficult to remove so formatting and fresh install is recommended. – drk.com.ar Jul 4 '14 at 13:29
  • 1
    I had a similar problem that turned out to be a "wild" interrupt from my WiFi adapter. Simply leaving the adapter turned on fixed it. Installing Process Explorer (which you can download free from Microsoft) provides a bit better view of this. – Daniel R Hicks Oct 19 '14 at 12:36
  • Given those symptoms I would worry about ransomware that hadn't finished encrypting and shown itself. – Loren Pechtel Feb 6 '16 at 3:04
1

It's fixed now, reinstalled windows, but the motherboard had been damaged after the CPU running high all time. I have had it replaced and now it's just fine :D

  • 4
    why was this downvoted? While it is not an ideal solution, it is what worked for OP – Saggio Nov 6 '14 at 22:37
0

For disk usage, it's normal, Antimalware Service Executable sometimes checks some files on hdd, so for what regards disk usage, don't worry. For cpu usage, check with another operating system as drk.com.ar suggested.

0

You can refer to this answer for a couple of steps to troubleshoot interfering or unwanted applications (answer here):

Although this may be overkill, I'd not say that there's some malware that specifically prevents you to do that, but maybe an app that interfers with the expected behaviour:

  1. Run a check using anti-malware tools, like Adwcleaner or MalwareBytes, just in case.
  2. Open the msconfig utility: Win+R and execute msconfig.exe.
    • Disable any unwanted applications that run on stratup.
    • On the Services tab, disable any unwanted services that run at startup too. You may want to mark the Hide Microsoft services so that you don't disable anything important accidentally.
    • By default, the msconfig utility marks the disabled services as Disabled, which means that you can't execute them even manually. Alternatively, you can execute the services.msc utility so that you locate such services and change their state to Manual, so they don't run on startup automatically but you'd still be able to start them if you need them.
  3. Reboot and see if something changes, then you can start re-enabling services and apps on startup until you detect which one is causing you trouble.

There are many causes to the behaviour you experiment and these are some steps that may come in handy to detect your issue, but of course it's not the only solution.

If you can't remove that rootkit from windows but you know where it is located, you can use the Linux Live CD (as suggested in the comments) to remove that file.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.