4

I recently noticed Google Docs is very slow on my MacBook (mid 2011 with OS 10.8.5) when using it in Chrome (latest version 35.0.1916.153). Safari seems to be doing OK. Tested it on another MacBook of same vintage, same issue. The main thing that seems to be slow is the update of the address bar with # anchors when moving from a paragraph with one style to a paragraph with another style. I work on documents with a lot of headings and just navigating them is painful.

Has anybody else encountered this behavior? Any clues on what's causing it?

2

Try this - it worked for me:

Deleting the "Default" profile seems to have resolved all the issues (per the Chrome help pages):

  1. Quit Google Chrome completely.
  2. Go to the Go menu > Go to Folder.
  3. Enter the following directories in the text field, then press Go. ~/Library/Application Support/Google/Chrome/
  4. Locate the folder called "Default" in the directory window that opens and rename it as "Backup default."
  5. Try opening Google Chrome again. A new "Default" folder is automatically created as you start using the browser.
  • 13
    You should add that deleting a profile removes all settings, bookmarks and saved passwords. – hultqvist Oct 6 '14 at 7:33
  • 1
    I had the same problem. Using Safari fixed it. I should note that I've got a pretty minimal Chrome install - i.e. few extensions and I've deleted cookies, etc. – Snowcrash Feb 2 '15 at 17:02
  • Confirmed that this method works for me. It's so strange to see that the issue is still around in the latest Chrome versions... – Ducky Sep 28 '15 at 1:20
  • Doesn't work on my iMac late-2014 (5K). Chrome has been resetted and it still lags. Moved to Safari. – TheOnlyAnil Mar 23 '18 at 9:42
  • Handily, although you are signed out of everything, the Extensions are left intact :) – RedYeti Apr 21 '18 at 10:43
8

Can be an extension which is causing the slowness.

Try open a new private window (private windows - or "incognito mode" - doesn't load extensions by default), access your document and test. I had the same problem and to me was the "recent tabs" extension.

  • 2
    It was the "recent tabs" extension for me too. – Roger Dahl Mar 10 '15 at 4:57
  • Yeah "Recent Tabs" was the culprit for me too! – Yash Sep 9 '16 at 10:41
  • Me too! I emailed the creator to try and fix it. – Overload119 Dec 3 '16 at 18:48
4

If you are using an AdBlock extension try disabling it for docs.google.com. This worked for me!

2

As @daniel-loureiro said, it very well could be an extension. Trying this in an incognito window would help narrow down or eliminate that potential cause. One thing to note when trying in incognito is all extensions should be on the default setting of not allowed during incognito. Go to Menu --> Tools --> Extensions and make sure that

Allow in incognito

is unchecked. Also, if it is up to speed in incognito with these settings, there are two ways to further narrow down which extension is causing the issue.

  1. Disable all extensions in normal browsing (see checkbox next to name) Enable one at a time to get an increasing number of extensions until something breaks the speed. (same method is also applicable vice versa, disable each one till solved)
  2. Without messing with normal browsing, use the "Allow in incognito" option doing the same , allowing or disallowing one at a time until resolved.

Seems at first like slow internet speed for those bad load times at # anchors, but then you said you had tested it in another browser.

  • Thanks. Unfortunately doesn't look to be the case. Tried running incognito without extensions, but the slowness remains. It was a very good idea though :). – gooli Jul 5 '14 at 6:30
  • The anchors thing makes me think against this, but chrome is sometimes a resource hog. Tried doing any maintenance on the system? – Tejas Manohar Jul 6 '14 at 1:28
0

update 04/24/2018: I upgraded MacOS to High Sierra version 10.13.4 and now the problem is completely fixed. Google Sheet is back to its "instant and snappy" speed. Very responsive now. Like others, I run on Google Chrome with a few extensions. The problem was not on those extensions as I ran the incognito mode test and concluded it was not their fault.

0

Please try turning off hardware acceleration by going to Menu > Settings > Advanced Settings > Under 'System' uncheck Use hardware acceleration when available. This worked for me in an instant. The other solutions didn't.

Let me know if this might help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.