I notice that my new Motorola Droid phone charges perfectly fine when I connect it to my computer via the USB cable, or if I connect it to a car cigarette Lighter -> USB adapter, or a wall Power -> USB adapter. It also works fine when I connect it to a powered USB hub that is connected to my computer.

However, if that same powered USB hub is not connected to my computer when I connect the phone, it does not charge. If I connect the computer to the hub, and then connect the phone to the hub, it will charge. If I then disconnect the computer from the hub, the phone will continue to charge.

Does anyone know why this is happening, or what I can do to be able to charge my phone from a powered hub, without my computer being present?

  • Wait, what? Your USB Hub have a big battery or something? And why so many answers without questioning this?! Am I going insane? I get a very similar symptom on my macbook with my iPhone, but it has a battery! Of course a unplugged usb hub wouldn't charge: it has no energy! - nevermind :P
    – cregox
    Sep 13 '11 at 13:06
  • related: superuser.com/questions/96563/…
    – cregox
    Sep 13 '11 at 13:56
  • @Cawas, it is a powered usb hub (as mentioned in the question, and originally in the title before Tom Wijsman edited it). Thus, it is plugged into the wall power.
    – pkaeding
    Sep 14 '11 at 0:53
  • I should begin using drugs to have justifications in those cases...
    – cregox
    Sep 14 '11 at 0:56
  • 1
    (I posted the answer below about modifying a USB hub). Regarding that other answer/the CNET article it seems pretty likely that they didn't mention that the hub was attached to a computer. I've never gotten ANYTHING to charge at all from a non-modded powered hub, and I tried a bunch when I was trying to figure this out. Frankly I'm surprised nobody sells such a thing since it's so incredibly useful (hello, entrepreneurs!) but it's a pretty low-risk project and the hubs are dirt cheap if you mess it up. Been using one for over a year now and it charges everything fine.
    – jamietre
    Sep 23 '11 at 20:30

Note that the USB Specification somewhere says that devices that are only connected but haven't "authorized" yet may only drain 100 mA instead of the usual 500 mA. It could be that your USB Hub simply does not supply the full 500 mA if it isn't connected to a PC, to be in line with the standard.

Wall chargers ignore that as they aren't USB devices but simply Power Bricks that output 5V/500mA on a connector that looks like a USB Port.

Edit: Copy/Pasting from Wikipedia:

Some non-standard USB devices use the 5 V power supply without participating in a proper USB network which negotiates power draws with the host interface. [...] The typical example is a USB-powered [...] battery chargers (particularly for mobile telephones), [...]. In most cases, these items contain no digital circuitry, and thus are not Standard compliant USB devices at all. This can theoretically cause problems with some computers; prior to the Battery Charging Specification, the USB specification required that devices connect in a low-power mode (100 mA maximum) and state how much current they need, before switching, with the host's permission, into high-power mode.

  • What will mark a USB hub as having this feature? Do they advertise it?
    – palswim
    Jun 26 '12 at 18:14
  • @palswim Usually not, at least I have never seen it. It's a gamble I'd say, hence I usually use USB Wall Chargers or the port directly on my PC.
    – Michael Stum
    Jun 26 '12 at 18:31
  • I can confirm that, to my displeasure, the Sitecom CN-051 has this 'feature'.
    – Joost
    Jan 8 '15 at 20:48

I think the answer is simpler. The two data lines only need to be shorted to each other and not connected to any voltage. I tried this with my Droid and it works. This seems to be part of the USB specification (from http://pinouts.ru/Slots/USB_pinout.shtml):

"A simple USB charger should short the 2 data lines together. The device will then not attempt to transmit or receive data, but can draw up to 1.8A, if the supply can provide it."

I connected my Droid to a 5V power source using a USB cord that I had opened up, cut the two data lines (white and green) and shorted them to each other on the Droid side. It charged perfectly.

  • +1 this is part of the USB standard, which the Droid follows (nothing else did.)
    – Broam
    Mar 4 '10 at 18:49

USB is a host-based protocol, relying on the PC for a lot of things. It's quite possible that the way the Droid is designed, it disables power flow to the connector unless it detects a host connection or the wall adapter.

I've also heard of certain cases for the Droid causing charging issues, but that's probably just for cases that have a passthrough connector between the one on the phone and the data cable.

I suppose it's also possible that the hub is not quite providing enough power without both the computer and the hub power connected, if it's defective.

  • Hmm, that is interesting. The hub successfully charges my iPod (through a builtin dock connector) and a bluetooth headset through usb. I tried disconnecting all of that stuff, though, and connecting the droid, and it still doesn't work. So I don't think the hub is defective and not delivering enough juice.
    – pkaeding
    Dec 2 '09 at 3:47
  • 1
    I've tried this with my Blackberry before and the hub wouldn't charge my Blackberry without a computer being attached. I would assume that it won't work and that you need an actual AC adapter or a PC to charge.
    – mrdenny
    Dec 2 '09 at 6:38
  • 2
    It's due to the Droid actually following the USB standard. I have a phone that does the same thing (it's so bad that in fact there are options to force 500mA draw).
    – Broam
    Mar 4 '10 at 18:48

I used the following method to get my Motorola Droid phone to charge from a wall-powered USB hub.

1) Open the case and solder together pins 2 & 3 of each USB connector where it is soldered to the circuit board.

2) Cut the traces on the circuit board coming from these two pins only (carefully) on each port using an xacto knife to isolate those pins from the rest of the circuitry. This step may be important depending on your hub - in my case simply soldering the two pins together was not enough, and it did not work until I also cut the traces.

The hub will not, of course, work any more as a data hub connected to a computer after you do this, since you've severed the data ports.

This USB hub is a Belkin high-powered job with a 1.5 amp power supply, and after these mods the android charges fine. Works with several devices plugged in simultaneously, too.

I also have an iPad which, although it says it's not charging, does in fact charge when connected to this modified hub. The iPad claims to require 2.0 amps. After being plugged in for a couple hours it will reach full charge, despite the "not charging" indicator, so it works even for that picky device with 1.5A.


Not the answer you're looking for? Browse other questions tagged or ask your own question.