3

Suddenly dead keys are disabled, but I didn't change settings.

  • I'm running Windows 8.1.
  • I didn't spill anything over the keyboard.
  • The apostrophe ('), double quote (") backtick (`) circumflex (^) and tilde (~) are inserted instantly into a text field which has the focus, instead of waiting for the following typed character in order to determine if these can be combined. Now I cannot type fiancée, août, señorita, geïnteresseerd, and überhaupt.
  • I suspect restarting the computer will solve the issue, but that's not an elegant solution.

Is there some keystroke in Windows 8.1 which silently enables or disables dead keys? And how can I re-enable them?

Notice that I didn't type abovementioned words, I just googled them to make my point. ;-)

0
  1. Make sure you, or a program you use, didn't accidentally or intentionally change your keyboard layout. Dead keys are not present by default on the English United States keyboard layout of Windows; otherwise, we wouldn't be able to type those characters (and we don't need to use them as dead keys to produce accented characters because English hardly ever uses them). One common shortcut is Ctrl+Space to toggle between two different keyboard layouts. If you have two layouts installed, one with dead keys and one without, you may have inadvertently hit this combination.

  2. Go into the Control Panel under Region & Language / Change keyboards and other input languages. Make sure the default language and default keyboard are selected correctly. If there are keyboard layouts added to your profile that you don't ever want to use, delete them from the list. See here for more info: http://windows.microsoft.com/en-us/windows7/add-or-change-an-input-language

  3. Try creating a custom keyboard layout based on the one you like, but with dead keys enabled (it's possible, though improbable, that some program you installed has modified the default keyboard layout to remove the dead keys...) http://msdn.microsoft.com/en-us/goglobal/bb964665.aspx

  4. Try actually rebooting, if none of the above help you. If this issue is non-reproducible (i.e., just some fluke), then you don't have to worry about it, as it won't be happening again. On the other hand, if this issue occurs again and again, and a reboot fixes it, then you should be able to pay closer attention to what activities you're performing on your computer, and frequently "try" to use your dead keys while doing your ordinary tasks, and see when they stop working. You may find a pattern, such as, "when I click X button on Y program, suddenly my dead keys become live keys" (or something like that). You may have to reboot and try several times to reproduce this behavior, but you'll at least get to the bottom of it eventually. There has to be some sort of deterministic correlation between the observed behavior and some action you, or a program, took.

0
0

Similar problem happened to me. Try to kill processes from the task manager (you should have Administrator permissions). First those which seem useless, then others and try the dead keys after each killed one. Do this only when nothing important is running on your computer since you can loose your data. After finding the process (if there is any), find the concrete solution.

It might be that some process simply alters this function or the process is malfunctioning itself for some reason. For example: process 'Delphi 7 Lite Register' can cause dead keys not to work. After killing this process, everything comes back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.