2

When it prompted me to import files, I clicked "never for this device" as a test while playing with other import options. How can I undo this? It's doing exactly as it says, as other cards still work, but not for this particular one. Thanks.

1
0

Go into Control Panel -> AutoPlay to get to the list shown below. Find the device (or the type of device), open the dropdown menu, and select "Ask me every time."

If that doesn't work, check to see if a program (that may no longer be installed) changed the value of the registry entry "NoDriveTypeAutoRun."

To correct the problem, open the Start Menu and, in the search box, type "regedit" and press enter. First thing to do here, is go to the file menu and select "Export..." and a backup of your current registry values in case you break something.

With in the Registry Editor, press Ctrl + f and type "NoDriveTypeAutoRun" in the search box. Once you've located the entry for "NoDriveTypeAutoRun," double click it to open the dialogue and change the value to zero.

This will reset all the AutoPlay settings to the system default. If you want something other than the default, take a look at the options below.

0×00000000 (0) enable all AutoPlay and AutoRun.
0×00000080 (128) disable AutoPlay on unknown reserved file type.
0×00000091 (145) default in Windows Vista and Windows 7.
0×00000095 (149) default in Windows XP.
0×000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.
0×000000FF (255) disable AutoRun/AutoPlay on all drive types.
5
  • I have tried this. I get prompted to choose, but when I choose the option to import via Dropbox, it does nothing. Meanwhile, the same steps for any other card works just fine. I imagine there's a "blacklist" somewhere. – Ryan Peters Jul 3 '14 at 18:15
  • What "cards" are you talking about? Did you try this with various SD cards? – PFitz Jul 3 '14 at 18:57
  • Yes. Particularly, a CF card worked, then I clicked "never for this device" (thinking I could undo it), then it stopped working (as expected). – Ryan Peters Jul 3 '14 at 19:03
  • Are you at all familiar with changing registry values? There are several third-party image editing applications that the change a particular registry value that causes this and it stays that way even if the application is uninstalled. – PFitz Jul 3 '14 at 19:17
  • I've updated my answer to include instructions on correcting the problem in the registry. – PFitz Jul 3 '14 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.