I have a Windows 7 64 bit system with 4 GB RAM and Intel i3 processor. I tried to install Avast 9 free antivirus and AVG in it several times, but I can't. I even tried to install it as admin, that too was unsuccessful.

Whenever I tried to install both, a Windows prompt appears(I clicked 'Yes' for it). The self extraction icon of antivirus program appears and nothing happens after it. Why can't I install antivirus ? How this issue can be solved ?


This is the screenshot of error message when I tried to install Avast 9 in safe mode.

enter image description here

  • 1
    A piece of malware I found on my machine some time ago yielded results much like this with every AV I tried. If AV is a no-go, maybe try a firewall (zonealarm or comodo). Or does this happen with other programs also?
    – ICE
    Jul 5, 2014 at 12:26
  • 1
    Yeah, it sounds likely that there is some malware on the box. You should perhaps try a stand-alone malware scanner (vs an AV kit you install). I don't have any to recommend, though. Jul 5, 2014 at 12:45
  • Instead of pirating Avast (which is, to be honest, not a very good AV), use MSE
    – Jon
    Jul 5, 2014 at 19:25

3 Answers 3


I encountered this as well, even in safe mode. Turned out to be some rogue .dll file watching for anti-virus installers, hogging resources when it found something.

Assuming malware (or some other infection), I would try trojan hunter, or maybe search & destroy.

Trojan hunter is what finally worked for me.


As said, it was a malware problem. I used Kaspersky TDSSKiller and I found the malware. Now am able to install antivirus.

  • This is a useful link to read after you [partially?] removed malware from your PC.
    – Hennes
    Jul 5, 2014 at 14:18
  • I do not think malware is ever "removed" from anywhere and it is quite rare that an infected or otherwise compromised machine has got only one piece of malware. I would go for a full wipe out and reinstall, and then enforce better safety policies, which not necessarily include the installation of an anti-virus software.
    – gd1
    Jul 5, 2014 at 15:58

It seems that the problem is that when your computer is extracting the files for some reason it is not executing the files. There are two way's of solving this.

The first and easiest way is to try another anti virus software (I would try this first).

The second more complicated way is to go to windows explore and type %temp% in the navigation bar and press enter. Then you must delete all the files in that folder. If it says This file is in use by anther process then just click skip. Then try to install the anti virus software again and it should extract the files into the %temp% folder. Then open up the folder(s) it makes and try running some exe files that are called something line setup.exe or install.exe or something like that.

Hope it helps. Let me know if it works for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .