I am trying to encrypt an entire USB drive with Truecrypt 7.1a. But as long as there is a partition it will only encrypt that. This will make it appear like the USB is full instead of completely empty, which isnt what Im aiming for.

I've tried with DISKPART, USB Partition Tool, and the built-in storage manager. When I delete all partitions, Windows still assigns the drive a letter and assumes that it has a partition covering the whole space.

I know that it is possible as I have done it with another USB, but I just don't remember how I did it.


  • Did you ever get this solved for windows?
    – Jon
    Apr 17, 2017 at 13:15

2 Answers 2

list disk

view USB disk number and type number in select disk

select disk 1

all partition delete in disk 1:

  • No luck. It still shows a partition in TrueCrypt.
    – Marcus
    Jul 5, 2014 at 11:42
  • You got the wrong drive then. This is the correct method and works instantly.
    – Daniel B
    Jul 5, 2014 at 11:58
  • Daniel: I did it with only one drive - besides the main harddrive - plugged in. So I did select the correct drive. Perhaps it's a bug in TrueCrypt then.
    – Marcus
    Jul 5, 2014 at 13:06

There is a tool that you can use called AOMEI Partition Assistant. You can use this to view the partitions on the USB flash drive, and you can also delete them.

AOMEI Partition Assistant

  • Same issue, unfortunately.
    – Marcus
    Jul 5, 2014 at 12:57
  • @Marcus To be honest windows is a pain. It can only show one partition on a USB flash drive. It will always show the first one. Also you could try humouring windows by formatting it in windows explorer and try again. Let me know how it goes.
    – 09stephenb
    Jul 6, 2014 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.