0

Ok, this is a pretty specific issue and I am currently at wit's end here. First, I'll describe what I'm trying to do.

I have been playing with Vagrant and Puppet to set up a very small Arch Linux VM for Golang development. It's been a bit of a learning process for me and I've kind of fallen down a rabbit hole trying to configure and customise to my personal liking.

I've chosen i3 as my window manager after viewing this nice setup. The creator of the theme was nice enough to share their configuration files for others to use. You will notice the status bar at the bottom of the screen. This status bar is accomplished by using Conky to monitor various hardware stats.

From what I can tell, after reading various tutorials and instructions on i3's main website as well as other newsgroups, I have configured my setup correctly. However, when I enter i3, instead of a gorgeous status bar, I am greeted with the following message:

"Error: status_command is not executable (exit 126)"

Here is a screenshot of my VM with all associated configuration files within view:

enter image description here

Left Column: Are the contents to my i3 configuration file located at $HOME/.i3/config. The uncommented status_command points to a bash script that feeds i3 polling data regarding my hardware and how to display it in the status bar below.

Middle Column: Are the contents to my status bar configuration. This is in the format of a streaming JSON document that i3 parses. Every iteration is supposed to update the associated data in the status bar below. This has been properly configured as per instructed.

Top Right: The output generated by . $HOME/.i3/conky.sh. This is the same command run by the i3 configuration file. As you can see, it is generating proper JSON output along with various stats ready to be parsed.

Top Right Middle: The directory listing of $HOME/.i3/. As you can see, the conky.sh script as execute permissions setup and is owned by the vagrant:vagrant user/group entity. Since i3 runs as under the same identity, it should have executable access to the script.

Top Right Bottom: This is the content of the $HOME/.i3/conky.sh shell script. Created as per instructed at the i3 conky instructions page here.

Despite the fact that I have followed all instructions and done everything I know to be correct. I still get the same error. I'm fairly certain there's some mundane little setting I'm overlooking.

Anyone care to help? I'll be more than happy to answer any questions and provide more information.

0

Well, I did a metric ton of digging around and simply could not establish the root cause of the issue. I, instead, opted to use i3blocks. I couldn't get the same level of detail as I would have with Conky, but this will do for now.

https://www.dropbox.com/s/kqroe3dcfz1li5k/happeh.png

1
  • 2
    Your link is dead. – Iiridayn Sep 7 '16 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.