10

Im using Fedora 10 with Synergy from Windows 7

When ever i use my keyboard through synergy and type @ i get the Omega Sign

Any ideas, or someone had similar problems?

5 Answers 5

12

I had problems with @, <, and >, so I did the following:

Code:

xmodmap -e "keycode 53 = x X greater greater greater greater"
xmodmap -e "keycode 52 = z Z less less less less"
xmodmap -e "keycode 24 = q Q at at at at"

Which solved those three... though I have no idea why the problem occurs in the first place.

5
  • My keyboard on the linux machine works fine, Its on Synergy that it fails.
    – whoami
    Dec 2, 2009 at 12:00
  • 1
    @Systech I just added your work around to our bug tracker. Jan 13, 2010 at 17:38
  • 2
    @nbolton Any chance of an actual fix instead of this workaround? Sep 17, 2014 at 14:59
  • 1
    Boy.. How you worked that out I'll never know, I thank you. My wife thanks you!!! Mar 2, 2016 at 12:15
  • I lose it when I reset the machine though :( Mar 14, 2016 at 16:14
4

This is a known issue, and we're working on it right now. There are several work arounds however, so if you take a peek at that issue, you may find something. If you have a Google account, you can star the issue to get a notification when it's fixed.

2
1

Create a file ~/.Xmodmap and add the following to it:

keycode 53 = x X greater greater greater greater
keycode 52 = z Z less less less less
keycode 24 = q Q at at at at

You can activate it straight away with:

xmodmap ~/.Xmodmap

I believe this will activate automatically when you reboot - but I hardly ever reboot, so haven't tested this.

Thanks (and +1) to Systech's answer for the contents of the file, and thanks to this page for instructions on how to make it persist across reboots.

0

pobably a keycode translation problem. Have a look at the synergy configuration. You should use the same language settings as locally

2
  • i cant find the synergy config on fedora any ideas?
    – whoami
    Dec 2, 2009 at 12:01
  • There are two possible locations for the synergy server config file, either ~/.synergy.conf or /etc/synergy.conf - however, this will not help fix the issue, since it's a software bug and not a config problem. Jan 12, 2010 at 5:47
0

locate synergy.conf, its probably in /etc

1
  • The synergy server config is also located at ~/.synergy.conf (but modifying the config is unlikely fix the problem). Jan 12, 2010 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.