0

I have a fresh install of Windows 8.1. I installed a program 'RackAFX' but it just won't start. I double click the icon and nothing happens.

I have already installed BOTH the x86 and x64 re-distributables, as mentioned on the RackAFX download page.

Once or twice, Windows reported that 'RackAFX has stopped working' and gave some error codes shown in the following screenshots:

http://i1219.photobucket.com/albums/dd427/Dave_Chambers/64Error_zps2f61e3bd.png enter image description here

I tried all possible 'compatibility' options too and running as administrator but it still won't open. Now Windows doesn't even give the 'RackAFX has stopped working'. A double click results in a spinning circle near the mouse and then nothing.

Anyway, trying to debug I installed RackAFX on both my wife's Windows 8.1 machine and my old clogged up Windows 7 partition (on the same machine as the problematic partition) and it works no problem. I also tried updating Windows 8.1 on the new partition but it still doesn't work.

I then also added another Windows 7 partition to my new hard drive and installed RackAFX but same thing - it won't open.

Not sure if this helps but this SO post describes how to find the LOC related to 'Exception Offset':

https://stackoverflow.com/questions/2528776/windows-c-is-it-possible-to-find-the-line-of-code-where-exception-was-thrown

So, in summary, RackAFX won't open on a freshly installed Windows 7 or Windows 8.1.

0

You are probably missing one or more for the MS VC redistributables.

From the RackAFX downloads page:

32-Bit Operating Systems If you are not using VisualStudio 2008 and you are installing for the first time please also download and install the VS2008 C++ Redistributable x86 (it’s easy, quick and free). If you are going to use VS2008 then you don’t need the Redistributable as it will be installed automatically by VS2008.

64-Bit Operating Systems If you are installing for the first time please also download and install the VS2008 C++ Redistributable x64 (it’s easy, quick and free). You still need this, even if you are planning on using VS2008.

UPDATE: A book reader who is using Win8/64-bit and Visual Studio 2013 reports that you need to install BOTH the x86 and x64 re-distributables. This is because VS2013 no longer installs some of the required files.

0

The problem was that the driver for my soundcard hadn't yet been installed and so no default in/out device was selected. This caused the program to crash. Installing the driver and choosing an in/out resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.