2

Error 0xc000007b when trying to start \EFI\ubuntu\shimx64.efi (Ubuntu) through Windows 8.1 Bootmanager on an UEFI System

EFI Entries

During Ubuntu Setup, Ubuntu automatically created an EFI start Entry called ubuntu. The entry works, if I use the UEFI Bootloader directly. My EFI Boot entries looks like this:

Entry #9
Name: ubuntu
BCD ID: {a738afa2-8136-11e3-824f-806e6f6e6963}
Device: \Device\HarddiskVolume3
Bootloader Path: \EFI\ubuntu\shimx64.efi

Entry #18
Name: Windows 8.1
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.efi

Use a device - Submenu

I want to start ubuntu through Windows 8.1 Bootloader. At the Windows 8.1 Bootloader screen you have the option to selecect Use a device in a submenu. In this submenu there are all existing UEFI Bootloeader listed. I can select ubuntu and after a reboot i can see correctly the GRUB screen.

Add Entry to Windows 8.1 Bootloader

Now I add the existing Entry from the Use a device to primary Windows 8.1 Bootloader list:

bcdedit /displayorder {a738afa2-8136-11e3-824f-806e6f6e6963} /addlast

bcdedit output:

c:\>bcdedit /enum

Windows-Start-Manager
---------------------
Bezeichner              {bootmgr}
device                  partition=\Device\HarddiskVolume3
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  de-DE
inherit                 {globalsettings}
integrityservices       Enable
default                 {current}
resumeobject            {dd3893a3-8112-11e3-a3ae-ef458f8a8f20}
displayorder            {current}
                        {dd3893a8-8112-11e3-a3ae-ef459f8a8f20}
                        {a738afa2-8136-11e3-824f-806e6f6e6963}
toolsdisplayorder       {memdiag}
timeout                 5

Windows-Startladeprogramm
-------------------------
Bezeichner              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 8.1
locale                  de-DE
inherit                 {bootloadersettings}
recoverysequence        {dd3893a5-8112-11e3-a3ae-ef458f8a8f20}
integrityservices       Enable
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {dd3893a3-8112-11e3-a3ae-ef458f8a8f20}
nx                      OptIn
bootmenupolicy          Standard

Firmwareanwendung (101fffff)
----------------------------
Bezeichner              {a738afa2-8136-11e3-824f-806e6f6e6963}
device                  partition=\Device\HarddiskVolume3
path                    \EFI\ubuntu\shimx64.efi
description             ubuntu

If I then select ubuntu from the primary Windows 8.1 Bootloader list following Error occurs after a reboot (It is translated so the original English wording could be different) :

Error during start of Windows.

File: \EFI\ubuntu\shimx64.efi

State: 0xc000007b

Info: The Application or the Operating System could not be loaded, because a required file is missing or it contains mistakes.

Note the Entry from Use a device still works. So what had happened? It should be the same entry?

Add Entry Manually

I also tried to add an entry manually:

bcdedit /create /d "Ubuntu Test" /application bootsector
bcdedit /set {UUID_generated_by_/create} device partition=\Device\HarddiskVolume3
bcdedit /set {UUID_generated_by_/create} path \EFI\ubuntu\shimx64.efi
bcdedit /displayorder {UUID_generated_by_/create} /addlast

But the same error occurs.

  • What filesystem is used on the partition shimx64.efi resides on? – Daniel B Jul 6 '14 at 17:05
  • It is a EFI-System Partition, 100MB in Size, created by Windows 8.1 and is formatted as FAT32 as it should. Tree of files if you need them – F.Raab Jul 7 '14 at 16:31
  • From a previous answer using Mac: does the file "\EFI\ubuntu\shimx64.efi" actually exist in your Ubuntu install? – Kinnectus Jul 8 '14 at 13:21
  • Yea does it. See here for a list of files in the EFI- System partition. If not GRUB should not be working (with the other boot options). Or does you mean something else with "in your Ubuntu install"? Linux does also simply mount the EFI-System Partition in /boot/efi. – F.Raab Jul 8 '14 at 13:38
0

Although I cannot verify it now due to lack of time, according to this guide, the correct entry type is bootsector, whereas the entry type in your configuration is somehow that of a firmware application. I suggest recreating the entry.

asdf

  • Thanks, well the {a738afa2-8136-11e3-824f-806e6f6e6963} works outside the primary Windows 8.1 Bootloader list and was created by the Ubuntu Setup, so it should be theoretically correct. that was my thought ... Nonetheless I also found the guide you mentioned and so I also tried an bootsector entry. See Add Entry Manually Section in my question. But the bootector entry produces the exactly same error ... – F.Raab Jul 8 '14 at 13:31
  • @F.Raab Well, I was able to reproduce your issue. I guess there’s no solution, just use Grub as the primary boot manager. – Daniel B Jul 9 '14 at 20:37
  • 1
    Well then my TPM Module does not work, so that is also not a solution for my problem^^ ... – F.Raab Jul 10 '14 at 10:09
  • @F.Raab Wow, okay, didn’t see that one coming. Maybe you’ll have better luck with rEFInd. Other than that, I’m out of ideas, sorry. I’ll try one more time with Windows 7 though, just for fun. – Daniel B Jul 10 '14 at 11:01
  • Yea that's OK^^ maybe another one has an idea. rEFInd is maybe an workaround since it does not load the kernel, so it might work ... mhmm perhaps I try if I have time. – F.Raab Jul 10 '14 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.