I have a brand new Windows 7 laptop, I've changed the desktop background picture using the "personalization" item of the desktop right click menu.

Below the list that of images to choose there's a drop down with options "stretch", "fit", "tile", etc.

When I change that from stretch to anything else nothing happens, and when I return to that dialog the drop down is still on "stretch".

Anyone knows what's going on?

Edit: Apparently this is a known problem with HP/Compaq laptops.


Are you using an HP/Compaq machine? Try this:

  • Go to HP Support and Drivers website
  • Choose Download drivers and software under "Select a task and enter a product name/number:"
  • Enter your product name (e.g. pavilion 2022. Be careful as the precise model is may be important.)
  • Click on the link matching your PC model
  • Choose Windows 7 operating system
  • Scroll down the list Select software and drivers
  • Choose Wallpaper picture position enabler

Paraphrased and updated from a post by Sharon Roffey in Background won't divert from Stretch Option on the Microsoft Answers site.


I've had a similar problem with the change not happening, to which the solution is rather silly. After making a change to your setting, you need to select "Save Changes" at the bottom.

Hopefully that should work.

  • Also note the change only applies to any images selected at the time. Each image can be set individually in Windows 7. – BinaryMisfit Dec 2 '09 at 13:42

Try this next time:

Right mouse desktop, goto Personalize, then Display. It will bring up a "Make it easier to read" window. By default, my installation was set at 150% and i ended up with the same problem with both BGInfo and AWC (Automatic Wallpaper changer). Setting it to 125% or less seemed to fix it.


Instead of changing the wallpaper by Right Click > Set As Wallpaper

Here is the quick easy way to fix:

Right Click > Personalize > Desktop Background > Browse

Go to the file you want as your background.

It will show up the same size/resolution that it is on the file.

  • No, it was a bug in some driver for that laptop model and the only way to fix it was to download the "wallpapaer picture position enabler" program from the HP website. – Nir Mar 11 '14 at 14:18

In case anyone else has trouble with this, I also have an HP laptop but found the fix didn't work for me. I worked out in the end that by right clicking and selecting the image as the desktop background, automatically puts it into the Windows Photo Viewer folder. Whether you center, tile or do anything makes no difference and the image always remains stretched. If you right click on the desktop, personalize, Destop background, and actually browse for the image instead then save, it centers.


you can open image with windows photo viewer, then right click and set image as background. this will set the background with the fill option, not stretch. you still will not be able to change background position, but in some cases the fill option is way better than stretch

  • 1
    Please don't post answers to questions which are not answers for them. If you could answer and provide your opinion that would be more valuable. Additionally, things like this would be much better as comments when you are able to leave them. – Abraxas Feb 18 '16 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.