1

I set up an a Ubuntu Server with LAMP and am trying to access it externally.

What I did:

  • I set up an account at no-ip.com following this article

  • I gave the server a local static ip of 192.168.1.127 and forwarded the port 80 and 22 (both externally and locally) to that ip adress. I also forwarded port 50005 external to port 80 internal.

  • I found my external ip via Portcheckers. To my understanding, the external ip is the same for all computers and routers on my network.

    The problem

  • I check ports 80, 22 and 50005 with portcheckers and all of them (along with all other major ports) were said to be unavailable.

  • I also tried to ping my server's external ip from portcheckers and got Ping Failed: TimedOut I tried pinging the ip address from the terminal, but it froze after PING myhost.no-ip.org (66.XXX.XXX.XX) 56(84) bytes of data. When I tried to connect to the sever though my browser I got the Oops! Google Chrome could not connect to... message.

    Info

    I can connect to my server locally(192.168.1.127) through ssh, sftp, and http.

    I have a Linksys E320 router, and I disabled the firewall.

    Please let me know if I need to provide my external ip. Thanks for the help.

    EDIT

    I modified /etc/apache2/ports.conf to listen to port 50005 instead of 80 by replacing Listen 80 with listen 50005

    • You should generally never disable your firewall. First get pings and such to work using IP address, then figure out DNS issues. Be sure you are checking your public IP address using a source outside of the local network (portcheckers is fine). Set up port forwarding on an unused port (e.g. 63242) and set up the web server to serve on that port, then test. It's possible your ISP blocks inbound traffic on popular ports. Also, check if UFW is running and what ports it is blocking with sudo ufw status. – Paul Jul 7 '14 at 0:36
    • Have you tried using the No-IP update tool? From memory they refer to it as DUC. – Michael Frank Jul 7 '14 at 4:23
    • @MichaelFrank I thought the update tools were only used if the server has a dynamic local ip address – TAAPSogeking Jul 7 '14 at 4:33
    • @Paul I only disabled the firewall to troubleshoot. Relatedly, ufw is disabled. Do you have any suggestions as to how I could get pings and such to work using IP address? All the ports I scanned were unavailable and a port 80 redirect failed. I would assume that my main problem is that I can't externally ping my ip address – TAAPSogeking Jul 7 '14 at 4:39
    • @TAAPSogeking No, the tool is designed to keep your domain name in sync with your dynamically changing external IP. – Michael Frank Jul 7 '14 at 4:41

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Browse other questions tagged or ask your own question.