0

I am using Elementary OS (based on Ubuntu 12.04) and i would like to change the coloring scheme for Pantheon Terminal window.

Here's what i have tried-

  1. Elementary Tweaks
  2. Dconf Editor
  3. shell commands

None of them are getting the job done. It's extremely difficult for me to differentiate between a command prompt and other text.

This is what I would like to use

https://github.com/Mayccoll/Elementary-OS-Terminal-Colors

1

Customizing terminal colors via Tweaks/Dconf globally changes the colors of all terminal application. For example mc is completely unusable with the preinstalled terminal themes (at least for me).

It's extremely difficult for me to differentiate between a command prompt and other text.

In this case, you should take a look your ~/.bashrc file and try uncomment force_color_prompt=yes. This should give a colorized prompt after restarting terminal.

Change colors and other properities of the bash prompt, just edit in .bashrc:

PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\] \$ '

http://www.cyberciti.biz/faq/bash-shell-change-the-color-of-my-shell-prompt-under-linux-or-unix/ http://www.cyberciti.biz/tips/howto-linux-unix-bash-shell-setup-prompt.html

1

You may also try guide from Mayccoll, downloading and installing complete script.

First uncomment the following line in .bashrc:

 #force_color_prompt=yes

And then install style:

$ wget https://raw.githubusercontent.com/Mayccoll/Elementary-OS-Terminal-Colors/master/elementary.sh
$ chmod +x elementary.sh
$ ./elementary.sh

Replace elementary.sh with style that is available in the Mayccoll's Git.

Another way is to open style that you want to install and import values manually trough dconf:

org -> gnome -> pantheon -> terminal -> settings

Values are:

background_color - background
foreground_color - foreground
palette - palette
  • Thank you for your answer. I was able to theme my terminal, only dconf tools worked for me. executing individual bash scripts didn't do anything. – Ashesh Kumar Singh Mar 1 '15 at 6:26
  • Glad that worked for you! – user423645 Mar 1 '15 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.