My laptop's battery tray icon sometimes says "plugged in, not charging". How do I make the battery start charging again?

  • Lenovo X230, 6-cell battery, Windows 8.1 64-bit.
  • This question says that battery's firmware or driver would sometimes decide not to charge at near-full capacity. However, this has happened at various charge levels - for example, now it's at 53%.
  • Battery is at decent state - lasts several hours when unplugged.
  • Using original charger through a docking station, but I tried another charger connected directly, and the battery continues to not charge.
  • Tried restarting the laptop - still doesn't charge.
  • Tried to disable+enable the Microsoft ACPI-Compliant Control Method Battery device - still doesn't charge.

6 Answers 6


Solution: I shut down the laptop, took out the battery, waited 10 seconds, then put it back, and presto! Charges like a champ again.

Source: How to Fix- Plugged in, Not charging (warning: awfully-made video). The video also says you need to uninstall the Microsoft ACPI-Compliant Control Method Battery driver, but I didn't do it, and still solved my problem. YMMV, I guess.

  • Another data point: The battery in my ThinkPad T520 was not charging (but the laptop ran fine on mains power without running the battery down, and ran fine on battery power without the mains attached) and this worked. Even better: I didn't shut the computer down, just hibernated it. Apr 15, 2015 at 17:36

I would like to share my verified working solution on ThinkPad X230, Windows 8.1 (and for those looking for ThinkPad Power Manager in Windows 8.1):

  1. Disable anti-virus software

  2. Install Lenovo Settings Dependency package for Windows 8.1(no need to reboot when prompted)

  3. Install Power Management Driver for Windows 8.1 (reboot if prompted).

  4. Download Power Manager for Windows 7

    • Run the downloaded .exe file to extract files, which are stored, by default, at C:\DRIVERS\VISTA\PWRMGRV.
    • Manually set one by one on all .exe files to run in Windows 7 compatible mode.
    • Run setup.exe to install power manager (reboot if prompted).
    • Verify that installed .exe at C:\Program Files (x86)\ThinkPad\Utilities are all set to run in Windows 7 compatible mode (if not, set it each again manually).
    • Now launch pwmui.exe and everything works as before like in Windows 7.

Final note: when running Battery Maintenance > Battery Gauge Reset, be patient and set Windows 8.1's power options to "Maximize Performance". Keep AC power attached and wait 3 hours or more until reset is completed. The status tells you it's doing discharging or charging, time remaining shown is not accurate and sometimes doesn't seem to be moving/changing, just be patient!

Background Info

I have my X230 one year and a half. The battery suddenly stops holding power and appears losing capacity. Remembering Lenovo used to have Power Manger which can calibrate/reset battery gauge, I searched Lenovo website and the Internet and found nothing nor real solution for Windows 8.1. Some suggests adding/editing Windows registry to set battery "start charging" and "stop charging" thresholds, which I did but didn't seem to help much.

After pulling some hairs and a day trying, I finally got it working. Initially it showed my battery condition "poor" and holding only 10% of original capacity. Now it's in "good" condition and holds 99% of original.

  • I edited your answer to include the 3rd link you weren't able to. It will show up once it's been peer reviewed.
    – Kristian
    Jan 23, 2015 at 0:52

YMMV indeed. None of these worked for me so I started trying combinations - remover the battery, power up, uninstall the ACPI drivers, reboot, scan for new hardware to install up-to-date drivers (even though I'd reinstalled twice today and also confirmed the drivers were up to date), shut down, reinsert battery, power up, and now it's charging the battery again.


I had the same 'plugged in, not charging' problem earlier today. I'm using a Windows 7 Samsung Chronos laptop rather than a Windows 8 Lenovo but this issue seems to affect a wide range of laptops. Uninstalling the ACPI driver had no effect. Suggested solutions that involved unplugging the battery were not practical as Samsung has not designed this machine to have easy user access to the battery.

Quite by chance, I chose to pay some attention to the power cable connections. Like most laptops of my acquaintance, this Samsung has a standard two-section cable, with a 'brick' in the middle. After unplugging and replugging all three connections, the laptop started charging again for about 30 seconds before reverting to not charging status. This then made me suspicious of the power extension cable I was using, so I plugged the laptop power cable directly into a wall socket. This finally appears to have resolved my problem.

Everything I have read about the 'plugged in, not charging' problem suggests that there are many possible causes. However, I have not seen any previous reference to the solution that worked in my case. I hope that others may find this information useful.

BTW, I found the BatteryInfoView app from NirSoft useful while investigating this issue.


  • This is a really long-winded way of saying, "Check you have a good electrical connection between the mains and the laptop." You make a very good point but your answer would be much more useful if you edited out the lengthy narrative and just cut to the chase. Sep 5, 2015 at 18:25

Find the battery's ACPI driver in the Device Manager under Batteries. Uninstall it. Scan for hardware changes and allow the OS to reinstall the driver. Do not uninstall any other drivers.

This can also be caused by the laptop, or the battery, overheating.

  • You=quick! I tried disable/enable (edited question to note that), didn't try un-install/re-install - might try next time.
    – Jonathan
    Jul 7, 2014 at 8:10

most modern laptops/tablets (where you can't get to the battery espcially) now come with software that will automatically stop charging your battery and just run from the power lead instead, this is to protect your battery from being overcharged. it will normally be 'plugged in, not charging' anywhere between 80% - 100% battery remaining. Personally I wouldn't be worried as it is looking after your battery to ensure it will still hold a good charge in time.

hope this helps?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.