0

I am about to configure database schemas using Oracle Repository Creation Utility, but am hitting a snag. When I run ./rcu, terminal returns the following error: Exception in thread "main": java.lang.NullPointerException

The reason for this is that RCU is intended to be run on an 32-bit OS, and I am running Oracle Linux 64-bit.

According to the documentation I have been able to find, this can be solved by creating a symbolic link to the jdk folder inside rcuHome. The problem is that I am unable to find said folder.

I have made certain that JDK is installed, but for the life of me, I can't find the actual folder. I have gotten as far as /usr/lib/jvm/jre-1.7.0-openjdk.x86-64, but I can't find jdk, neither in /bin nor /lib.

I'll answer any questions as they come up and I have time, but any guidance would be greatly appreciated.

System: Oracle Linux v6u5, 64-bit, run as a Virtual Machine under VirtualBox.

0

Can you see the jdk package if you run this, or just the jre?

rpm -qa | grep jdk

If you have it installed, you might have multiple javas; just one is used, as default. At this point, I'm guessing you ran which java command, and saw just the jre path. Check alternatives command to get all java paths, and set java link to point to java JDK (if you want). Anyway, the idea is that you'll get all the java paths, and see where the jdk is. Alternatively, you can get all files installed by a package (thus the path of java) using repoquery -l <jdk_package>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.