Whenever I open Adobe Reader by opening a .pdf file on my system (Windows 7 x64) if the Internet connection is not available (no connection at all, or even wrong Internet settings, like a proxy that is not there), Adobe Reader will work for about 1 sec, then freeze for 8 sec or more, after which it will work normally.

When Internet is enabled, it freezes for less than 1 sec instead. No CPU activity, no network activity when Internet is disabled (of course), and memory load is 80 MB during the freeze, out of 100 MB when it finally starts to work.

To me, it is a distinct signature of a network process that conditions the execution of the entire application. Adobe is looking for something on the Internet, and won't allow any action from the user, even a scroll, until it's finished, or sure that the resource is unavailable, by...waiting for the timeout. And I'm waiting for that timeout too. Every time I open Adobe Reader after it was completely closed.

I've seen something about recently used files that are on an unavailable network location. I've tried reducing the recently used file list to 1 in the preferences/document menu, but this does not affect the complete list of recently used files, only what is displayed in the "file" menu.

None of the other answers (disable protected mode at startup, disable automatic authentication of signatures at startup, disable everything that required an automatic network action from adobe that I could identify) worked for me. The only thing I can do to work without this annoying interruption is to let the Internet on all the time, which is sometimes impossible.

If anyone has the REAL explanation to that problem, I would be very grateful. What is Adobe Reader looking for on the net that is so badly necessary that it has to stop functioning at all at startup until it finds what it's looking for?

Thank you for your help!

  • Have you also deactivated the Welcome screen? – Max Wyss Jul 8 '14 at 6:38
  • +1. This is exactly the problem I've been getting the last few months; as I don't let Adobe products talk automatically out to the internet. Internet access suggests feature bloat frankly. – LateralFractal Oct 30 '14 at 6:33
  • N.B. I've submitted a bug report to Adobe. As they use a completely opaque submission system, I've got no bug tracking number for you. Remains to be seen if the problem gets resolved. – LateralFractal Oct 30 '14 at 7:44
  • @MrBody Can you remove the last edit from your question and make that an actual answer? You can answer your own questions on SU, and you can even mark them as the correct answer afetr 48 hours. – Jan Doggen Nov 6 '14 at 10:25
  • @MrBrody - you should add your Edit as an answer instead, and mark it as 'accepted' so that other people know what worked for you – Robotnik Nov 7 '14 at 0:42

I had absolutely same symptoms as described above (8 sec freeze with disabled Internet and 1-2 sec with Internet). after trying most of the methods discussed here (disabling security mode in Settings and via regedit, reinstalling Reader, rebooting), I was experimenting on disabling plug-ins (.api) one by one to see if the problem was connected with one of them, and at least in my case it was!

in the end I found out that if you disable the Weblink plugin (see a how-to below), everything becomes normal! (although, alas, you loose the super-ability to follow web links from a PDF document — however, in most cases you can just copy the URL and paste it into your browser manually)

to disable the plugin you need to:

  1. shut down all running instances of AcroRd32.exe
  2. go to "C:\Program Files (x86)\Adobe\Reader 11.0\Reader\plug_ins\" folder
  3. cut the file "weblink.api" and paste it somewhere outside that folder (e.g. in a new folder such as "(...)\Reader\plug_ins_BAK\") — or simply rename the file changing the extension to get something like "weblink.api.bak".

then try to run Adobe Reader.

I had the same problem and one/all of the following things helped:

  1. Reduce the list of recently opened documents to 1 (I have several network drives and if those are not available Adobe Reader hangs while trying to do a file check) You can do this by setting the following option to 1: Edit->Preferences->Documents and there the option "Documents in the recently used list"
  2. Disable product messaging. You can do this by Edit->Preferences->General uncheck "Show messages at startup" and check "Don't show messages while viewing a document"
  3. As a last resort disable the option "Enable Protected Mode at startup" under Edit->Preferences->Security (Extended)
  • I did not know about the "disable product messaging". This might actually be it, although I'm not sure. I've already tried the other two, it did not help! – MrBrody Oct 2 '14 at 19:16
  • Sorry. None of these work. Although strictly speaking I should be downvoting Adobe developers instead an untested answer. – LateralFractal Oct 30 '14 at 6:54
  • This is not an untested answer since solution 3 worked for me. However maybe your problem is a different one... – Lonzak Oct 30 '14 at 8:51

Run Adobe Reader in Windows XP SP3 compatibility mode.

To do that:

  • Right click on the shortcut to the program
  • Click Properties
  • Click Compatibility
  • Under Compatibility Mode, select Windows XP (Service Pack 3)

I tested this for Adobe Reader 11.0.09.

up vote 0 down vote accepted

As suggested above, I transform my "Edit" into an answer.

What worked for me was to allow Adobe Reader to connect to the Internet (the tricky thing was I oscillate back and forth between proxy and no proxy at work and at home, and usually as I'm lazy I only set the proxy in Firefox, but not on the (Windows 7) system, which is what Adobe uses for Reader). After doing that, the next day, there was no problem anymore.

Once you do, and start Adobe Reader, you will still see the freeze, but only for about 0.3 s while it retrieves what it is looking for on the net. I still have absolutely no idea what exactly is this web routine doing and why it has to cause a complete freeze of Reader while it counts down the timeout when no Internet connection is present. The suggestion of chokingyou seems right, though I could not test it on my configuration and verify it, since I did not experience the problem anymore.

This is why I mark my answer as the chosen answer, and upvoted chokingyou's answer for those who want to know the real (and probable) ultimate cause of the problem.

  • With Acrobat XI running, open Windows' Task Manager (Ctl-Alt-Del will do).
  • Open "Processes" tab.
  • Look for "AdobeCollabSync.exe".
  • There should be only one copy running. If there are more than one, end them.
  • Close Task Manager, and see if Acrobat runs OK.

100% Solution Here

  1. Navigate to Menu>Edit>Security (Enhanced)
  2. Uncheck "Enable Protected Mode at Start Up" and press OK
  3. Restart Adobe Reader

All Set, let's go...

You can try:

  • Remove Adobe Reader from your computer
  • Reboot
  • Install it again (latest version)
  • Reboot then test.

If you're still having no luck, you could try Foxit Reader, which is an alternative PDF viewer.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.