1

I've been trying to use WICD-curses to connect to my Wi-Fi network. I thought it would be simple: I went to the config page for my network, entered the password at the bottom, hit F10, and waited for it to connect. It went through a few different stages before printing out "bad password" and going back to "not connected". I am sure that the password I entered is right, but I haven't been able to get it to connect.

The only thing that I have been able to find is that it says "WPA 1/2 (HEX [0-9/A-F])". Does that mean that it will not accept lower-case letters? I tried to change it to "WPA (passphrase)," which seems more correct, but I can't figure out how.

Can someone help me out with this?

1

Most people will want to choose "WPA 1/2 (Passphrase)". Which you can translate to "WPA 1/2 (ASCII)". Which for most people will translate to "normal, regular passphrase". Like "black_cat" or "my sWe3t p0r5ch3" or "mynetworkssid1". Just a passphrase.

"WPA 1/2 (HEX [0-9/A-F])" - well, that's if you happen to have your password written in hexadecimal, a.k.a. only using numbers and letter from A to F (A B C D E F). It's generated from passphrase and wi-fi network SSID.

To change it in wicd-curses, no rocket science, just press enter when inside config page for your network and the focus is on the list with encryption types (WEP HEX, WEP passphrase, WPA passphrase, open network...etc. etc.). Then arrows (up/down) and enter again. And F10 to save it all.

2
  • I figured that I wanted the passphrase, but I can't figure out how to change it. I'm working on a device with a 128-pixel-wide monochrome display, so text UIs aren't exactly user-friendly. I pressed enter and it brought me to a list, but the arrow keys didn't do anything graphically. Should I just imagine a pointer and hope I count right?
    – Wasabi Fan
    Jul 9 '14 at 4:13
  • Two ways I can think of, one is: wicd-cli. Pure command line interface for wicd, no ncurses, which you seem to have problem with. Second is: shut down wicd and edit wireless-settings.conf, on Debian: /etc/wicd/wireless-settings.conf. Find your network there, and look for "enctype = wpa". Change it to "enctype = wpa-psk". Save the file, start wicd once again.
    – bardzusny
    Jul 9 '14 at 4:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.