I have an old MS-DOS computer that I am experimenting with. The computer has an AMD 80386 processor, 1664 KB of RAM, a 50 MB hard drive, and two floppy disk drives: one 3 1/2 inch, the other 5 1/4 inch.

I am in the process of installing a C++ compiler on this computer (see Install C++ compiler on old MS-DOS computer with floppies for more details). In order to facilitate that installation, I am attempting to install a CD-ROM drive. The drive is a Top Glory Electronics BCD G621D. I have found the correct driver (http://www.driverguide.com/driver/detail.php?driverid=349099) and have followed the instructions in the manual (included in the driver download) to connect the drive to the system and install the software.

Currently the CD-ROM drive is hooked up as a slave drive to the HD, and the jumper is set accordingly. The drive is being powered correctly; it opens and closes as it should.

The driver is installed in D:\CDROM\, while the MS-DOS system files are located in the C: drive. I have added the following lines to the CONFIG.SYS and AUTOEXEC.BAT files, respectively:

DEVICE=D:\CDROM\CDROM.SYS  /D:MSCD001 /V

and

C:\DRDOS\MSCDEX.EXE  /D:MSCD001 /L:F

The former loads the driver into memory, and the latter configures the MSCDEX.EXE program to interact with the driver, thus allowing the user (me) to access the CD-ROM drive.

However, a problem has occurred. After installing the driver and restarting the system, one of two things happen: 1. Information about the driver is displayed. 2. An unusually large cursor flashes on-screen.

The information mentioned in item 1 is shown here:

ATAPI IDE CD-ROM Device Driver
Release DATE : 04/19/1999   TIME : 09:00:00
Example : DEVICE=CDROM_DRV.SYS /D:MSCD001 [/DMA]
/DMA  --> Enable PCI Bus Master DMA Mode
/UDMA --> Enable PCI Bus Master Ultra DMA Mode
Sound Card IDE Port 168 --> IRQ 10
Sound Card IDE Port 1E8 --> IRQ 11
Driver Version     : 2.9
Device Name        : MSCD001
Drive 0:  Port= 1F0 (Primary Channel), Slave  IRQ= 14
Firmware Version   : M1.30
Transfer Mode      : Programmed I/O mode4

In both cases, the DOS prompt never appears, and the system does not accept commands. Thus, the computer is rendered useless.

The problem appears to be caused by the line in CONFIG.SYS. When I boot MS-DOS from a floppy disk rather than the HD and remove that line from the file, the computer works just fine when I reboot from the HD. (Of course, MSCDEX.EXE cannot access the device, as the driver is not loaded).

This leads me to believe that I have the drive and its driver set up correctly. However, that does not help me considering that I am unable to do anything with the computer once the driver loads. Does anybody know how I would be able to gain access to the MS-DOS prompt and use the computer while the driver is loaded?

Thanks in advanced for your help.

  • Try removing the /V from the line in CONFIG.SYS. – LawrenceC Jul 9 '14 at 2:53
  • Good old days... remove C:\DRDOS\MSCDEX.EXE /D:MSCD001 /L:F from autoexec.bat and does it boot into DOS prompt? – Kenneth L Jul 9 '14 at 3:47
  • I tried removing the /V switch from the line in CONFIG.SYS and – Kyle Jul 9 '14 at 14:31
  • @ultrasawblade and @Kenneth L - I tried removing the /V switch from the line in CONFIG.SYS and removing the line from AUTOEXEC.BAT. Neither of those actions enabled the computer to boot into the prompt. – Kyle Jul 9 '14 at 14:45
  • 2
    Possibly this should be moved to the retrocomputing stack exchange. – dirkt Mar 12 '17 at 17:06

I think the clue is in the description box. Odds are, the sound card has an IDE port on it. Many, if no most of them do. Usually it can be disabled by a jumper on the sound card. You could temporarily remove the sound card. Or you could connect the cd drive to the sound cards IDE port.

Try using the Oak CD-ROM driver here. Make sure you add HIMEM.SYS as it directs.

Your system dates from the era when there were often issues with slaving two devices on a single IDE port that weren't from the same manufacturer and didn't explicitly support it. If you still encounter problems, attach to the other IDE port if your motherboard has one, or look on your favorite auction site for an ISA IDE adapter and see if you have better luck with that.

  • I was tempted to downvote based on the first sentence. But the rest of your answer was helpful, so I didn't. Still, although the OAKCDROM.SYS has a high compatibility rate, so do some other newer drivers that use notably less amounts of memory, and so OAK's driver is not the good driver to be recommending. – TOOGAM Feb 4 '17 at 17:58

I am going to go another direction. Simply rem out the line in the config.sys file that loads cdrom.sys and reboot. If you get a DOS prompt at that point then it is the cdrom.sys and you need to find a different one.

Just what you see on the screen:

Example : DEVICE=CDROM_DRV.SYS /D:MSCD001 [/DMA] /DMA --> Enable PCI Bus Master DMA Mode /UDMA --> Enable PCI Bus Master Ultra DMA Mode

is almost telling you that the command line isn't right. mscdex won't work with the cdrom.sys remed out but it won't affect anything.

I agree with the pause as the first line in the autoexec.bat to see just what the config.sys file did.

It is a very simple way to determing if the cdrom.sys is causing the problem....

I agree with the comment about removing MSCDEX from AUTOEXEC.BAT.

Maybe not a long term solution, but that could help to determine where the stability issue exists.

Try making the first line of AUTOEXEC.BAT this:

@Echo Off

And the second line this:

Pause

If the problem is the CONFIG.SYS driver, try changing it. I don't know just what DriverGuide offered you, but there are some drivers that tended to work on almost all drives, and use up far less conventional memory than most other CD drivers. See: TOOGAM's Software Archive: CD drivers for DOS for details. Because conventional memory was often important in DOS, I would be fairly try those drivers in just about any case, even if official manufacturer's drivers weren't causing stability issues. Confix.sys can also be useful, allowing you to echo messages and pause bootup during config.sys processing. This may really help you confirm that the config.sys line is what is causing stability issues.

If you're using MS-DOS 6 (or perhaps newer alternatives, like FreeDOS), then try holding F8 or Shift-F8 when booting. You may find that's an easier way to skip lines from the CONFIG.SYS file.

Your sample config.sys output shows quite a lot of IRQ info. Hardware conflicts can cause symptoms like what you describe: where the second time the computer boots then things don't initialize as desired. If you continue to have problems with different drivers, make sure that there's no conflicts of I/O address or IRQs (or DMA). That was a common source of problems with computers in that era, and can typically be fixed for free by just figuring out what hardware (or possibly driver) needs to have settings be changed.

This behavior can occur if any of the following conditions exist:

The CD-ROM driver or Mscdex.exe file is disabled (commented) or missing from the Autoexec.bat or Config.sys file.
The CD-ROM driver or Mscdex.exe file is missing or damaged.
The startup disk does not contain the CD-ROM driver or Mscdex.exe file.
You have replaced the original CD-ROM and not updated MS-DOS drivers. 

To access a CD-ROM drive when you boot to a Windows command prompt or restart the computer in MS-DOS mode, you must load the real-mode CD-ROM driver in the Config.sys file and the MSCDEX driver in the Autoexec.bat or Dosstart.bat file. If your CD-ROM drive is supported in protected mode in Windows, the real-mode CD-ROM and MSCDEX drivers are most likely not being loaded in the Config.sys and Autoexec.bat or Dosstart.bat files on the hard disk. In addition, if you boot from a floppy disk, the CD-ROM and MSCDEX drivers will not load unless you manually configure the Config.sys and Autoexec.bat files on the floppy disk to load them.

for resolve them see :

http://support.microsoft.com/kb/135174

  • Downvoting. This answer is useless. The information is right, and is related to the topic of the CD driver, but the instructions provided are exactly what the question-asker is attempting to do, and so this answer doesn't really help at all. – TOOGAM Feb 4 '17 at 17:59

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.