I got my media keys to work in the hotkeys under the settings, and they do work... when I have VLC selected. If I deselect it (not close the window, just click on another one) then the keys will not work. So, while playing Skyrim, I cannot press the next key and change the song, unless I select it first, which then the button is pointless. Please help. How do I get the Media keys to work while in another window other than VLC player?

  • you know application hotkeys will work only when you select the application. Assume you are working on a doc and you have selected and some other application and if you press any hotkeys then actions should reflect on application and not that opened doc obviously :) – Ten-Coin Jul 9 '14 at 5:20
  • @AgentCool While that's true with VLC, it's not true with many other media players. WinAmp used to be controllable from inside other apps using system-wide keyboard hooks. About the only time it didn't work was in a game using DirectInput which is why things like HLAmp came about – Basic Oct 5 '14 at 12:35
  • 2
    @OP - You asked a question and got the answer. Did it help? If not, then ask further for clarification. If yes - then mark the answer accepted so the responder gets credit and so others know it's the right answer. It's how the community works! – JoelAZ Jan 27 '15 at 19:25

From the VLC Wiki:

VLC Global Hotkeys are shortcuts you can use even if VLC does not have the focus. Here is how to configure Global Hotkeys:

  • Tools » Preferences » HotKeys
  • Under the Global column, double-click the value corresponding to the function you want a global key assigned to.
  • Press the key or key combination you want
  • Click Apply
  • Click Save

You will have to quit and restart VLC for the new assignments to be effective.

To unset/clear a global hotkey: Proceed as if you wanted to set a new key, but press the pause/break key.

  • Really helpful for me (Im not the asker). thanks. – TechLife Jan 21 '15 at 22:19
  • 13
    didn't realise it required a restart, thanks (Linux) – Hashbrown Jan 23 '15 at 3:11
  • Thanks! One note though, the Pause key (obvious choice for play/pause) doesn't work because it's the unset key although it looks as if it was set. One workaround is to use Alt+Pause. – SilentVoid May 17 '16 at 20:25
  • To reassign a key to another function you have to unassign the key, save, restart VLC, then assign the new function and restart again. Also, the current VLC version does not need the "pause" key to unassign anymore; it has a button in the "press key now" dialog for this. – Christian Oct 21 '16 at 20:34

This page seems to be the top result for this problem when Googling "vlc media keys not working", however the top (and only) answer doesn't actually address the problem. The information is useful for someone setting up VLC media key functionality for the first time but a bit of browsing around suggests that this problem persists for some people even after setting their hot key preferences.

There is another solution if your media keys refuse to work without VLC being the focused application:

Uninstall 'Microsoft Mouse and Keyboard Center'. This can be found in your Windows Control Panel's normal uninstall page.

This is some sort of bonus program that Windows Update may install if you have a Microsoft branded mouse or keyboard (possibly on your behalf) that as far as I can tell offers little meaningful functionality over standard Windows mouse options, especially if your mouse / keyboard is a basic one. When it is installed it seems to meddle with media key input, preventing VLC from detecting button presses when it is not focused.

If you have a volume control keyboard feature you may be able to test whether you have this installed. Simply use your keyboard volume control while on the Windows desktop. A light blue bar may appear at the bottom right of your desktop showing the change in volume, near the notification area. I believe this means the program is installed. If you uninstall the program this pop-up does not appear.

This was discovered and tested on Windows 7. I do not know whether this is relevant to Windows 8 or above.

  • This worked for me on Windows 8.1, I was able to bind the keys after uninstalling it and the keys worked after restarting vlc. – William Lawn Stewart Jan 24 '16 at 5:03
  • I agree with @Jonathan Rose (and I am one of the people who has Googled that my VLC global hotkeys don't work even after setting them up). Unfortunately, my Windows 10 PC doesn't have Microsoft Mouse and Keyboard Center, so my problem must be something else. I've also tried closing other programs that I thought might be blocking the hotkeys: AutoHotkey, Executor, Everything, Greenshot, etc. – Ryan Jan 26 '17 at 18:14

Try changing the settings in the Microsoft Mouse and Keyboard Center

  1. With your cursor, click on the Play/Pause button in the image of the keyboard (it should be highlighted in blue)
  2. Go to app-specific settings » Add New
  3. Select VLC » Select Play/Pause from the list
  4. Restart VLC.

I was having the same frustration and the steps above worked for me.

  • Hi, I cannot see a keyboard in my mouse and keyboard center (not ms keyboard), I can only see a mouse. What should I do? – Aero Windwalker Aug 18 '16 at 7:19

protected by Community Mar 12 '17 at 3:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.