29

When browsing, I tend to middle-click things I want to read so they load in a new tab in the background. That way they're ready to read when I finish the current page.

Recently the behavior changed in Google Chrome. Now when I select a background-loaded tab, my disk chugs for a long time instead of switching instantly. It doesn't actually build the background tab until I select it. And it takes longer for it to foreground it than it would have to just load it. (Note, I believe the page was downloaded from the internet, just not "imaged", since the disk chugs like it was paged out and it's not displaying the usual progress in the status bar at the bottom.)

What changed? How do I get the old behavior back?

Google Chrome: 35.0.1916.153 (Official Build 274914) m

OS: Windows

(I've googled for chrome, background tab, lazy load, delayed load, etc... no luck with any search terms after about an hour.)

EDIT: This recently stopped happening on all my computers within a one-week period. It looks to me that it was a change implemented in Chrome, again.

  • It looks there's not enough of memory. Chrome loads the page (disk clings), then the OS unloads that memory to paging file. When you click the tab, OS has to load that data from paging file into memory. – Alexey Ivanov Sep 5 '14 at 17:01
  • 1
    That was my first thought, too. But the machine has 16GB of RAM and was only using about 6GB. – idean Sep 5 '14 at 21:05
  • 1
    Hm… With 16GB of RAM, it doesn't look like the problem lies in memory. – Alexey Ivanov Sep 6 '14 at 5:32
  • I'm have the same situation with 48.0.2564.71 beta (64-bit) on linux. – Enkouyami Jan 14 '16 at 0:17
  • 3
    Try toggling the following flag and see if the problem is affected: chrome://flags/#enable-offline-auto-reload-visible-only – int_541 Jan 30 '16 at 4:28
22

INT_541 had the right answer above. Out of all the sites I checked, his was the only one that worked for me. I disabled the setting below and tabs started functioning like before (loading in the background). Without it, even tabs I had viewed would get unloaded until I viewed them again. It is nice to have this option if your bandwidth and PC can handle it.

chrome://flags/#enable-offline-auto-reload-visible-only

|improve this answer|||||
  • 5
    Just to reiterate, you have to change the setting to Disabled in order to enable tabs loading in the background. (It's a confusing double negative.) – wisbucky Sep 14 '17 at 10:14
1

You can in addition disable the offline auto reload in general. If you are like me only set your computer to sleep without closing chrome.

chrome://flags/#enable-offline-auto-reload

|improve this answer|||||
0

In chrome://flags/, set Enable tab discarding to Disabled.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.