8

For the couple of weeks a whole bunch of the songs from my iTunes library stop early and skip to the next song (just as if it was at the end of the song). Although the point where it skips varies for each song (for one song it is 2:32, another is 2:46), it will always skip at the same point for each song.

A while back I ran BPMer and, although it crashed half way through, it did not appear to corrupt my music the way it is now.

A few days ago I backed up my iTunes library and reformatted my hard drive (for a completely unrelated issue) and reinstalled OS X from scratch. The problem was happening before and after the reinstall.

This problem also persists when the music is synced across to my iPod touch running 3.0. Listening to the same troublesome songs in my iPod causes them to end prematurely. However, I can listen to the whole song using Quicklook, so the problem must be with my iTunes library or something.

3

Music options in iTunes inlcude a stop time. Ctrl-click->Get Info->Options will show you if these have be changed, perhaps by BPMer.

If that is the case, you can change the stop time in the info box for each song. If you don't mind losing play counts and ratings, you can re-import your music.

2

I had exactly this problem. I checked the stop time. It was 1) not checked, and 2) it was the correct time for when the song should have stopped. The song was stopping about 10 seconds before. I had another song from the same album that also stopped short.

These were songs purchased from the iTunes Store, not ripped.

The same song played correctly to the end on another computer. I recently transferred my music to a new computer.

On a hunch, I wondered if something was corrupted in the iTunes library file (which is an XML file).

I deleted the songs from the library, leaving the files where they were (not putting them in the recycle bin). Then I dragged those two songs back into iTunes so they would be reinserted into the library.

Now they play perfectly fine!!

1
  • Same problem here (not stop time related). A group of files imported together were stuck at 94 s. I reimported them: some worked, some didn't (at another time point). When converted from MP3 to AAC (using Audacity) and imported again, all worked. Seems one of these problems that are nearly impossible to track down... – pesche Jul 1 '12 at 12:29
1

Maybe your files are not corrupted, and is this related to something completely different.

Could check the following:

in iTunes there is an option under preferences (tab 'playback') named 'Crossfade' See whether it is turned on. If so, turn it of and check again if songs stop early. I was confronted with this when I downloaded a new version of iTunes, even though the setting was not set before.

1

I've had this issue for a while now, can't even be sure when it started though my suspicion is it came with my upgrade to snow leopard. Since then I had a number of itunes updates and due to my older machine am stuck at 11.4 now. The problem always remained. The one thing i Realized though is that it only happens when performing group import. So if you have a new album and drag all the songs into itunes, each and every song imported has the problem that it stops and skips to the next song halfway through. time would be random between songs, but consistent for each song.

Deleting the songs and importing them one at a time without changing anything to the meta data or file, solves the issue. More time consuming, but it has become a habit of me to import my songs like that.

I've never found an answer that actually fixes the issue rather than using the workaround i just described. If anybody knows the real fix, i will be very happy to know.

Leon

1
0

I suspect that these files were corrupted (some meta-information iTunes and the iPod needs) in some way when you ran BPMer.

If the music was imported/ripped from an Audio CD, I would reimport/recreate the mp3 files from the original source.

3
  • That is what i initially thought, but the problem arose a while after i ran BMPer – Josh Hunt Jul 18 '09 at 8:49
  • Maybe iTunes at some point tried to "fix" something BMPer didn't break. – splattne Jul 18 '09 at 8:54
  • I've had exactly the same song-truncation problem without using BPMer or any other third-party application. There seemed to instead be a connection to a failed iPod sync. I just plugged the iPod into the computer as always and received an error message in iTunes, but disconnecting and reconnecting the iPod appeared to fix the problem. However, several albums had truncated song times afterwards. These songs, which are from CDs and not the iTMS, are synced to two different iPods, by the way. – David Kolar Aug 9 '09 at 1:17
0

They may have gotten corrupted because you played them while they were downloading. Delete them and then re-import them.

0

Similar issues here with an iPod 180gb Classic.

I found that the songs that were giving me grief were those that had been converted by myself at some point into AAC format using iTunes.

As I hade plenty of space I reconverted them all back to MP3 format and the issues stopped.

I use MP3 format for all of my music now.

0

I recently had this issue after having to recreate my entire library from a backup (a hard drive had failed).

This was on a PC, and the solution I found was to stop itunes, delete the itunes .itl file, restart itunes and let it rebuild the library from the xml file (make sure that the xml file exists and is up to date before doing this).

I did this after checking there was nothing wrong with the files themselves (if I re-added a file, it was fine), and also checking that no 'odd' options had been set on the files (e.g. a particular stop time).

You will lose some file info doing this (last played, album artwork), but the artwork will be rebuilt (generally correctly, although some 'odd' choices can occur).

1
  • On El Capitan with iTunes 12.5.1, there is no option to rebuild the library from xml file. Or am I missing something? – Wildcard Sep 27 '16 at 10:03
0

I have the same problem, and let me tell my solution before sharing my case's specifics. Solution that work for me: -> only files with bitrate 320kpbs are affected. So I deleted them from the LIBRARY, then using audio converter I reformatted them into lower bitrate, and drag them back.

My case: I'm using itunes for windows. All my files are in mp3. Most (all?) of the affected files seemed to be cut off exactly at 3.58 mark. Files older than 3 months ago, with bitrate 320kpbs doesn't have this problem, so something because of iTunes update afterward?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.