13

How do you turn on the Ignore permission errors option in WinSCP?

I keep getting a prompt do to so, but when I search through the preferences I cannot find any such option.

30

Go to Preferences > Transfer > Default (or whichever preset you are using) > Edit > check Ignore permission errors (in the Upload options section).

enter image description here

| improve this answer | |
  • 1
    Work only of SFtp – user956584 Sep 25 '14 at 15:59
  • A very good example of poor usability! – Ahmad Aug 25 '19 at 17:47
6

The answer by @ᔕᖺᘎᕊ is correct regarding enabling the option.

See the documentation for details:
https://winscp.net/eng/docs/ui_transfer_custom#upload

Though note, that it is only a workaround, as the full error message says:

Upload of file ... was successful, but error occurred while setting the permissions and/or timestamp.

If the problem persists, turn off setting permissions or preserving timestamp. Alternatively you can turn on 'Ignore permission errors' option.

So you should consider following the advice and disabling setting permissions or timestamp, if you do not have a permission for that. Otherwise you may end up ignoring errors you might actually be interested in.

For details see the documentation for the error message:
https://winscp.net/eng/docs/message_preserve_time_perm

| improve this answer | |
  • 2
    It helps when the author of the software himself gives the answer :) – danno Aug 9 '17 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy