5

I'm running Kali Linux 64bit 1.07 as a guest os through virtualbox 4.3.12 r93733. I've also installed the VirtualBox 4.3.12 Oracle VM VirtualBox Extension Pack. I have bridged my hosts network connection (Intel(R) Wireless-N 7260) with Kali and I have set up the Alfa 036nha as a usb device for Kali through virtualbox.

iwconfig in Kali gives no wireless extensions.

ifconfig shows my bridged connection and Local loopback.

lsusb shows: Bus 001...... Atheros Communications, inc. AR9271 802.11n

I thought that maybe it didn't have the right drivers so i tried to apt-get install firmware-atheros but it said that it was already installed.

I really don't know what I should do here.. anyone care to help me out? You should now that I'm not too good with Linux etc.

Edit: I found this https://www.youtube.com/watch?v=K1ETBeRQBs4 Which helped me getting the Alfa card to work in Kali. The trick was to add a new custom USB device in virtualbox where you just take the vendor ID and product ID from the alfa device and leave the other boxes blank.

So now when i run ifconfig I get that wlan0 is up (Alfa) but eth0 is down (Intel(R) Wireless-N 7260).

Now however the problem is that when I plug in the Alfa device my network connection from my other wifi ceases to work (Intel(R) Wireless-N 7260) (the connection bridged from my host). It disconnects in the host aswell. If I connect to a wifi (with 7260) in the host with kali and alfa running the alfa stops working in Kali... I want to have them both running.

Anyone knows how to fix that?

  • If there are any suggestions about using the AWUS036NH that'd be great since I'm having this same issue but with the Ralink chipset. – slow_excellence Jul 10 '14 at 19:43
  • I'm really surprised by the number of answers that this question got. – Don't Root here plz... Oct 28 '16 at 14:29
1

Buy powered usb hub + Y cable, run adapter through thst Usually problem is electricity with usb can't provide enough for adapter.

  • 1
    OP already answered his question so this answer is not needed. – Davidenko Jul 17 '15 at 5:52
  • 3
    The answer can be useful for other users who have similar issue and possibility that youtube file couldn't help them. It was my experience which helped me to fix the issue, I like to share it with others as it would be helpful, if not helpful definitely not harmful as well! – Botmaster Jul 17 '15 at 6:17
1

I tried everything on this post without success, the blinking green icon on the USB controller wasn't happening for me.

So after researching for some hours, and trying several ways to troubleshoot the issue, the answer for me was to set the USB 3.0 (xHCI) Controller under USB settings on virtual box, I believe this feature is available on Virtual box 5.0.16 and up.

Selecting USB Controller 3.0

0

This somehow solved my problem https://www.youtube.com/watch?v=K1ETBeRQBs4. The additional problem I talked about only seems to be present sometimes and most of the times both wlan interfaces work.

0

This answer fixed this issue exactly as described above.

apt-get install firmware-atheros

Try to uninstall and reinstall the firmware if it already exists:

 apt-get remove firmware-atheros

 apt-get install firmware-atheros
0

If anyone followed the video the OP posted, got wlan0 showing up in ifconfig but are stuck with the virtual box USB indicator blinking red

From Youtube user Stas Sorokin posted in the Youtube comments of the video mentioned by the OP:

The trick is to go to your kali settings in VB go to network, select "enable network adapter" and the "not attached" option then run virtual box with kali linux, then after kali loads connect the network adapter, and let it load. After half a minute go to Devices -> usb devices -> and select your adapter

Then it should load.

0

Running Kali 2019.1, on VirtualBox.

do sudo apt update; sudo apt install realtek-rtl88xxau-dkms;

Once I did that, I heard my Alfa disconnect and reconnect from Windows, and all of a sudden, I had wlan0 interface. No reboot needed.

source:https://www.kali.org/releases/kali-linux-20171-release/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.