I'm running Kali Linux 64bit 1.07 as a guest os through virtualbox 4.3.12 r93733. I've also installed the VirtualBox 4.3.12 Oracle VM VirtualBox Extension Pack. I have bridged my hosts network connection (Intel(R) Wireless-N 7260) with Kali and I have set up the Alfa 036nha as a usb device for Kali through virtualbox.

iwconfig in Kali gives no wireless extensions.

ifconfig shows my bridged connection and Local loopback.

lsusb shows: Bus 001...... Atheros Communications, inc. AR9271 802.11n

I thought that maybe it didn't have the right drivers so i tried to apt-get install firmware-atheros but it said that it was already installed.

I really don't know what I should do here.. anyone care to help me out? You should now that I'm not too good with Linux etc.

Edit: I found this https://www.youtube.com/watch?v=K1ETBeRQBs4 Which helped me getting the Alfa card to work in Kali. The trick was to add a new custom USB device in virtualbox where you just take the vendor ID and product ID from the alfa device and leave the other boxes blank.

So now when i run ifconfig I get that wlan0 is up (Alfa) but eth0 is down (Intel(R) Wireless-N 7260).

Now however the problem is that when I plug in the Alfa device my network connection from my other wifi ceases to work (Intel(R) Wireless-N 7260) (the connection bridged from my host). It disconnects in the host aswell. If I connect to a wifi (with 7260) in the host with kali and alfa running the alfa stops working in Kali... I want to have them both running.

Anyone knows how to fix that?

  • If there are any suggestions about using the AWUS036NH that'd be great since I'm having this same issue but with the Ralink chipset. Jul 10, 2014 at 19:43
  • I'm really surprised by the number of answers that this question got. Oct 28, 2016 at 14:29

7 Answers 7


Buy powered usb hub + Y cable, run adapter through thst Usually problem is electricity with usb can't provide enough for adapter.

  • 1
    OP already answered his question so this answer is not needed.
    – Davidenko
    Jul 17, 2015 at 5:52
  • 4
    The answer can be useful for other users who have similar issue and possibility that youtube file couldn't help them. It was my experience which helped me to fix the issue, I like to share it with others as it would be helpful, if not helpful definitely not harmful as well!
    – Botmaster
    Jul 17, 2015 at 6:17

This answer fixed this issue exactly as described above.

apt-get install firmware-atheros

Try to uninstall and reinstall the firmware if it already exists:

 apt-get remove firmware-atheros

 apt-get install firmware-atheros

I tried everything on this post without success, the blinking green icon on the USB controller wasn't happening for me.

So after researching for some hours, and trying several ways to troubleshoot the issue, the answer for me was to set the USB 3.0 (xHCI) Controller under USB settings on virtual box, I believe this feature is available on Virtual box 5.0.16 and up.

Selecting USB Controller 3.0


Alfa AWUS036NHA device problem - error 43 - device descriptor request failed (code 43) if switches between systems and VM.

problem solution - TP-link driver for Atheros AR9271 chipset

link - https://www.tp-link.com/en/support/download/tl-wn722n/v1/#Utility - choose V1 - V2/V3 different chipset
direct link - https://static.tp-link.com/resources/software/TL-WN722N_V1_Utility_140918.zip

after installed this driver (need run installed file "an administrator" and "compatibility mode for Vista" (maybe can mode for Win7 - i not tested it) AWUS036NHA device was detected by Win10 as TP-LINK Wireless USB Adapter

AWUS036NHA (TP-LINK Wireless USB Adapter) switches between systems without any problems. at boot VB Kali - disconnected from Win10 and connect to Kali, after Kali shutdown, device connected to Win and show in device manager again.

test system - Win10pro (2004.19041.546) and Kali (2020.3) on VirtualBox (6.1.14 r140239 (Qt5.6.2))


This somehow solved my problem https://www.youtube.com/watch?v=K1ETBeRQBs4. The additional problem I talked about only seems to be present sometimes and most of the times both wlan interfaces work.


If anyone followed the video the OP posted, got wlan0 showing up in ifconfig but are stuck with the virtual box USB indicator blinking red

From Youtube user Stas Sorokin posted in the Youtube comments of the video mentioned by the OP:

The trick is to go to your kali settings in VB go to network, select "enable network adapter" and the "not attached" option then run virtual box with kali linux, then after kali loads connect the network adapter, and let it load. After half a minute go to Devices -> usb devices -> and select your adapter

Then it should load.


Running Kali 2019.1, on VirtualBox.

do sudo apt update; sudo apt install realtek-rtl88xxau-dkms;

Once I did that, I heard my Alfa disconnect and reconnect from Windows, and all of a sudden, I had wlan0 interface. No reboot needed.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.