2

Unfortunately it seems like the normal C-b > PgUp or C-b > ctrl+arrows aren't working; instead, I'm just seeing the characters 5~ be printed whenever I C-b and then try to use PgUp. Even mouse mode scrolling (which I would prefer to avoid anyway) just prints characters to the screen instead of moving the buffer.

Is there some additional config I need to be using? I'm using mintty, tmux is launched from bash and has its default shell set to fish.

  • I have the same issue. The only way I've found to get around it is to use a program like autohotkey (I think that's the name of it -- my computer is at work) to send the correct key sequence and bind that to some other key sequence, like Ctrl--/Ctrl-+. It used to work but stopped for some reason, and I never went back to figure it out. It could be that I simply don't remember the correct key sequence to trigger it... – Joe Casadonte Jul 17 '14 at 1:09
  • IIRC, there are three keys to munge in this manner, the one to put you into Copy-mode (I think that's what it's called), then the Page-up/Page-down keys. – Joe Casadonte Jul 17 '14 at 1:10
0

I had this problem when I had a typo in my .tmux.conf. It needed to say set-window-option -g mode-keys vi but it said set-window-option -g mode-keys vim. Of course, I did not have any keys bound for "copy-mode-vim".

If you recently switched versions of tmux from 1.x to 2.x, the tmux.conf syntax may have changed for you as well. You'd see errors on tmux startup if that is the case.

As a reference, if you're interested, I have the following working keybindings show up when using :list-keys

Puts you into copy mode with Ctrl+b PgUp

bind-key    -T prefix       PPage             copy-mode -u

Uses PgUp and PgDn when already in copy-mode:

 bind-key    -T copy-mode    NPage             send-keys -X page-down
 bind-key    -T copy-mode    PPage             send-keys -X page-up

Used PgUp and PgDn when already in copy-mode-vi

 bind-key    -T copy-mode-vi NPage             send-keys -X page-down
 bind-key    -T copy-mode-vi PPage             send-keys -X page-up

Posting the output of C-b :list-keys and your the contents of your ~/.tmux.conf would help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.