19

I've tried to do some research to figure this out, and per this Technical Q&A:

USB Prober is installed as part of the Developer SDK installation. If the Developer SDK has been installed, then locate USB Prober at /Developer/Applications/Utilities/USB Prober.

I'm on Mavericks 10.9 and don't have a /Developer/Applications/Utilities folder.

My IOS Simulator is located here:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Applications/

So I searched in all of the subfolders of /Applications/Xcode.app/Contents/Developer/ and even /Applications/Xcode.app/ but didn't find anything with a name like USB Prober.app

I don't see anything in the downloads section of Xcode:

enter image description here

How can I install the Developer SDK and get access to the USB Prober utility?

  • 2
    Did you ever resolve this? I'm running into the same thing. The docs are pretty outdated as there hasn't been an Xcode-installed "Developer" directory for at least the last couple of years...I also downloaded the Hardware IO tools from Apple and they do not contain USB Prober. Let me know if you figured it out. I'll do the same. – Reid Sep 18 '14 at 21:28
  • 1
    @ReidBelton - I think I ended up somehow finding a way to test using an Ubuntu machine. I would still like to know the OS X way. – cwd Sep 19 '14 at 2:33
  • 1
    @ReidBelton - did you see the new answer posted here? – cwd Sep 26 '14 at 2:20
  • Thanks so much for pointing that out, I would not have seen it otherwise! You rock! – Reid Sep 26 '14 at 14:38
28
+50

USB Prober.app is not included in Xcode

enter image description here

Search for iOUSBFamily and download the latest version on the developer page

Installing the package is not recommended as it will overwrite your installed kernel extension, and can cause kernel panics at startup if the version downloaded does not match the OS.

Instead, after downloading

  1. mount the downloaded .dmg.
  2. Within the folder without the suffix "-log" in the name, right click on the IOUSBFamily-xxx.x.x.pkg and select "Show Package Contents".
  3. Double click on Contents/Archive.pax.gz to unarchive. Unarchived files are typically placed in a folder named "Archive".
  4. Look within that for DevTools/Hardware/USB Prober.app.
  • 3
    I am on 10.10.1 and the latest version I can find is for 10.9.4. Running USB Prober (just as you described) works, but as soon as I start the USB Logger, it would just hang. Does anyone else have some positive experiences on Yosemite using the USB Logger? – vinzenzweber Jan 5 '15 at 18:26
  • 1
    I am on 10.9.5, installed iOUSBFamily for 10.9.4. On starting USB Prober.app it said I did not have kexts installed and if I would like to automatically install it. I chose to install it and so far seems to be working as expected. – AJP Jan 7 '16 at 13:23
  • I definitely posted that comment too soon. I found the device but nothing was shown when I tried listing to the traffic by going to the "USB Logger" panel and clicking "Start". Any ideas? – AJP Jan 10 '16 at 15:11
  • 2
    Also getting an error when starting the USB logger on OS X El Capitan 10.11.5: USB Prober: [ERR] Could not IOServiceOpen on USB Controller client e00002c7 – donturner Jun 30 '16 at 10:05
  • 1
    iOUSBFamily hasn't been updated since 2014? Is there a newer name? – endolith May 11 '18 at 20:46
7

All of those warnings that come with USB Prober scared me away. Instead, I used IORegistryExplorer, and it works fine for me in OS X 10.10.2.

• In ADC "Downloads", search for and download the "Hardware I/O Tools for Xcode - October 2013". (Change I/O to IO or the search won't match.)

• Open the downloaded disk image.

• You will find a "IORegistryExplorer.app" in the package.

• Connect your USB device.

• Launch IORegistryExplorer.app.

• You'll see an outline with hundreds of entries. To find the device you are looking for, you'll need to guess some search terms that describe it, and enter them into the search field. For example, I was looking for an RS-232C device, so I entered "RS".

• When you think you've found the entry for your device, disconnect it. If you are correct, the entry's text will become red strikeout, then if you plug it back in, a new entry will appear in green text, turning to black after a few seconds.

  • 2
    Hey Jerry, I've successfully located the device I'm looking to sniff the USB traffic from but am not sure what you then do to see the traffic. I tried to find some more information so I open the About page to find: "Engineering: If you can call it that. Human Interface Design: To some degree... Testing: Well, at least a little. Documentation: Someday" Lol! :P They have a sense of humour which is good but alas that's not helpful in sniffing USB traffic. – AJP Jan 8 '16 at 11:13
  • AJP, I do not think that IORegistryExplorer has a feature to monitor USB traffic between a device and some other application. I do not know of any tool to do that, or if it is even possible. – Jerry Krinock Jan 9 '16 at 17:20
  • Apparently the USBProber.app should be able to provide that information but I can't see anything at the moment. – AJP Jan 10 '16 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.