9

I was setting up a RHEL7 server in vmware vSphere and I'm having trouble getting it on the network without NetworkManager. I configured the server to have a static IP during the install process and it set everything up using NetworkManager. While this does work we do not use NetworkManager in my office, so I went and entered what we usually put the config file to get RHEL6 servers online without NetworkManager.

/etc/sysconfig/network-scripts/ifcfg-ens192 is the following:

NAME=ens192
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=no
BOOTPROTO=static
IPADDR=10.0.2.15
PREFIX=24
GATEWAY=10.0.2.2

However when I disable NetworkManager the network service fails to start with the following error

#service network restart

Restarting network (via systemctl): Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.

And both commands output the following:

network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
network[1838]: RTNETLINK answers: File exists
systemd[1]: network.service: control process exited, code=exited status=1
systemd[1]: Failed to start LSB: Bring up/down networking

Also, here's what the command 'ip addr' outputs:

1: lo: mtu 65536 qdisc noqueue state UNKNOWN
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens192: mtu 1500 qdisc noop state DOWN qlen 1000
     link/ether 08:00:27:98:8e:df brd ff:ff:ff:ff:ff:ff

  • RTNETLINK answers: File exists means that whatever network.service tried to add (probably IP addresses) were already there. Run ip addr and add the results to your question. – BenjiWiebe Jul 11 '14 at 22:45
  • I recently debugged an issue with network.service and the best way to track the ip commands was strace. You shouldn't generally get this type of error. It might be worth reporting (ideally via support). – Pavel Šimerda Apr 5 '15 at 5:40
2

Check your MAC Address for the VM. It should be 08:00:27:98:8e:df since that is what is shown you ran ip addr. If it's anything else, you will need to set it in your ifcfg-ens192 file with the following, but replace the address with the actual.

HWADDR="08:00:27:98:8e:df"

I had the same issue and this solved it for me.

  • The configuration file in the Question apparently relies on NAME=ens192 without any MAC address matching. – Pavel Šimerda Apr 5 '15 at 5:43
1

All I found that it takes to resolve this is that MAC in the Config

 NAME=ens192
 TYPE=Ethernet
 ONBOOT=yes
 HWADDR="08:00:27:98:8e:df"
 NM_CONTROLLED=no
 BOOTPROTO=static
 IPADDR=10.0.2.15
 PREFIX=24
 GATEWAY=10.0.2.2

If you are not sure of the hardware address you can find it in.

 cat /sys/class/net/ens192/address
1

Try to go to the virtual machine network settings and make sure the network cable is connected and check if you have blocked this with a firewall.

0

you should put that information (GATEWAY=10.0.2.2) in /etc/sysconfig/network once it's done, restarting the service should succeed

0

I too came across "Failed to start LSB: Bring up/down networking" error, since disabling NetworkManager. It took two minutes to be brought up interfaces after boot. The cause of confusion was "... LSB". It turned out the message comes out from just the traditional /etc/rc.d/init.d/network script. In my case, following solved the problem;

To network-scripts/ifcfg-eth0 added

NMCONTROLLED=no

Removed unnecessary ifcfg-* files which NetworkManager has left behind

# rm /etc/sysconfig/network-scripts/ifcfg-Wired_connection_?
0

This will solve the problem!

# rm /etc/udev/rules.d/70-persistent-ipoib.rules 

# reboot
  • Now edit /etc/sysconfig/network-scripts/ifcfg-eth0,
  • Add new HWADDR generated or remove it
  • Remove UUID line

-Restart the networking service

 #systemctl restart network.service

NOW! Working.

0

NetworkManager dictates the default route ( ip route ) even though your interface has nm disabled, it is just that interface not the whole system.

ps aux | grep -I net   # will probably find NetworkManager still running.
chkconfig network on
systemctl disable NetworkManager.service
systemctl stop NetworkManager.service
  • 1
    systemctl disable doesn't stop a service, nor does chkconfig ... off which basically translates to the same command anyway. – Pavel Šimerda Apr 5 '15 at 5:42
-1

I was having the same issue. So I just delete the backup files I made in /etc/sysconfig/network-scripts, such as ifcfg-Bridge_connection_1.home and ifcfg-Bridge_connection_1.office which I created for backup usage. They should not be created there. The /etc/init.d/network restart could work well after delete those useless ifcfg-*.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.