I'm having issues resolving the NetBIOS name of a new FreeNAS server.

I can ping and access CIFS shares by IP i.e. \\

I cannot ping or access by the NetBIOS name FREENAS

Running nbtstat on the IP shows the correct name, and the cache includes the name, but the commands still fail. Both machines are set to WORKGROUP. I can browse and view other Windows machines, but previously I have also had similar issues on non Windows devices trying to find my PC by name.

ipconfig lists the Node Type as Hybrid which should do a broadcast lookup first.

I'd rather avoid editing hosts files to add a static lookup if possible. Apart from that though I'm fairly stuck, I've googled and checked a bunch of registry options without much luck.

C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Nick-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

C:\Windows\system32>nbtstat -A

Local Area Connection:
Node IpAddress: [] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name               Type         Status
    FREENAS        <00>  UNIQUE      Registered
    FREENAS        <03>  UNIQUE      Registered
    FREENAS        <20>  UNIQUE      Registered
    WORKGROUP      <00>  GROUP       Registered
    WORKGROUP      <1E>  GROUP       Registered

    MAC Address = 00-00-00-00-00-00

C:\Windows\system32>nbtstat -c

Local Area Connection:
Node IpAddress: [] Scope Id: []

                  NetBIOS Remote Cache Name Table

        Name              Type       Host Address    Life [sec]
    FREENAS        <20>  UNIQUE           600

C:\Windows\system32>ping FREENAS
Ping request could not find host FREENAS. Please check the name and try again.


Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64

OK after some effort it's now solved. I feel a bit stupid but will share in case it helps anyone.

I ran nbtstat -a PCNAME on all the computers and noticed a __MSBROWSE__ line on more than one.

It took me a while to figure out but apparently one of the computers had an incorrect subnet mask of instead of This lead to multiple master browsers and all kinds of confusion.


I had a similar issue when I added a secondary ip address to an Ethernet interface.

The "Ethernet interface" had two ip addresses:

  1. as primary
  2. as secondary

The host I tried to access was in the primary domain.

When I tried to ping the NetBIOS name, it failed to resolve the address. I checked the Netbios status by:

nbtstat -c

Node IpAddress: [] Scope Id: []

    No names in cache

It reported only the secondary ip address as node address. When I removed the secondary ip address, the netbios name resolution started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.