1

I'm attempting optimize my setup between Windows Media Player and a SmartTV that uses Windows Media Player's playlist to display and stream files.

Even though my computer has the proper codecs and plays them in Windows Media Player, it ignores all default unsupported file types. This is making it difficult for me to add new folders into what's shared. (As it won't display the files that aren't WMV, AVI, etc.)

Is there a way to force Windows Media Player to associate and show all file types in it's playlist?

I'm able to get them to play and stream, I'd just need to either open each one manually from my computer, or trick WMP into thinking it's supported by renaming the file .WMV. (Which, is a tedious task.)

Just in case you still don't understand, I'm using WMP's Oragnize > Manage Libraries > Videos, then selecting folders with videos there. When I select the folder, it doesn't queue it because it's filled with "unsupported" types. (Even though it's supported.)

To make it clearer, this is not about file playing support. It's about getting the playlist to queue "unsupported" file types it doesn't like. All these files play just fine in WMP.

  • There's no way to force WMP to pick up all file types. For starters, it won't know which unrecognized file types are music and which are video. Support needs to be added in the registry on a per-file type basis. Usually the codec installer takes care of this. Which specific file types do you need to have picked up by WMP, and which codecs did you install for playback? – Tim De Baets Jul 21 '14 at 21:33
  • Filetypes like MKV & OGV. Would I be able to add it to the Windows Registry manually to let WMP recognize it? I found another solution to this problem, but knowing I can do this would be nice for the future if I ever need to use WMP again. – IceSage Jul 23 '14 at 3:15
3

For WMP's library to recognize and pick up MKV files, copy/paste the following into Notepad, save it as WMP_MKV.reg, double click this file to add it to the registry, and restart WMP:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.mkv]
"PerceivedType"="video"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"PerceivedType"="video"
"Permissions"=dword:0000000f
"Runtime"=dword:00000007

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\MLS\Extensions]
"mkv"="video"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"PerceivedType"="video"
"Permissions"=dword:0000000f
"Runtime"=dword:00000007

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MediaPlayer\MLS\Extensions]
"mkv"="video"

It might be necessary to re-add the existing MKV files in WMP's library if they're already in Other media instead of Videos.

For other file types, you can simply replace all occurrences of mkv in the registry file above with the other file type, and also add the resulting file to the registry.

-1

A little add-on to the precedent answer that helped me a lot :

file mkv.reg ----------------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT.mkv] "PerceivedType"="video" "Content Type"="video/mpeg" @="mpegfile"

[HKEY_CLASSES_ROOT.mkv\OpenWithList]

[HKEY_CLASSES_ROOT.mkv\OpenWithList\wmplayer.exe]

[HKEY_CLASSES_ROOT.mkv\OpenWithProgIds] "mpegfile"=hex(0):

[HKEY_CLASSES_ROOT.mkv\PersistentHandler] @="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions.mkv] "PerceivedType"="video" "Permissions"=dword:0000000f "Runtime"=dword:00000007

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\MLS\Extensions] ."mkv"="video"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Multimedia\WMPlayer\Extensions.mkv] "PerceivedType"="video" "Permissions"=dword:0000000f "Runtime"=dword:00000007

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MediaPlayer\MLS\Extensions] ."mkv"="video"

end of mkv.reg --------------------------------------------------------------

worked fine for me on windows xp with WMP 10

  • 1
    Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Jul 5 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.