4

I was looking at a friend's Toshiba laptop which after a random amount of time, maybe 30 or so seconds from boot, the (touchpad) mouse cursor freezes permanently. The computer as a whole does not crash; TileWorld continues to update dynamic content and some things can be done by keyboard manipulations. However, I am not aware of the mouse unfreezing with the exception of some multitouch gestures. Before it froze, I didn't notice anything unusual about touchpad behavior.

What if anything can be done? Is Windows having trouble talking with the touchpad? Should I explain to my friends that the children should not be watching Disney's Frozen on their laptop when a large TV is available?

Thanks

2
  • What is your Toshiba's Model? As Maxim suggests, please try updating the drivers if you haven't already. If we know the model, it may make it easier for us to help you find a solution. Edit: Check Event Viewer. Open search, type Event Viewer, open it, go to Applications and see what Messages are there. If something is going wrong, there's a good chance that there will be an error or message of some sort in Event Viewer that helps explain things a little more. – jay_t55 Jul 14 '14 at 1:56
  • 1
    Thanks, @Aeron! The machine is a Toshiba Sattelite S855D-S5120. I installed Windows updates and attempted to update the driver via Device Manager, but it said I already ha the most current driver. – Christos Hayward Jul 14 '14 at 17:21
2

Same thing happened to me, but I found a quick fix. The Toshiba is a poorly made machine - the Function hot keys seem to be very sensitive. My touchpad periodically freezes, and I just hit F5 (the touchpad on/off toggle - other models need Fn+F5), which solves the problem every time. My guess is that the button is just going off on its own. Annoying, but a quick fix.

0

As many things in Windows are fixed by closing and opening them again,

for me shutting the lid of the laptop and re-opening worked.

0

In my case, I stopped encountering the mouse freeze when I realized that it happened whenever the disk defragmenter was running in the background. The hard disk is the slowest element in the computer, and defragmentation involves copying large chunks of data to various parts of the hard disk.

To switch off the automatic defragmentation:
Open Windows Explorer and right-click on the disk drive icon. Select Properties and press the Tools tab.

Here under Optimize and defragment drive, click on the Optimize button. The Optimize Drives box will open. Click on the Change settings box.

Uncheck the Run on a schedule check-box and Click OK.

Defragmentation will be disabled.

source: http://www.thewindowsclub.com/disable-defragmentation-ssd

OR

Log on to Windows 8 using administrator account.
Hover mouse to the bottom-right corner of the screen.
Click Search.
Type Schedule Tasks and select it.
Locate and select Task Scheduler Library > Microsoft > Windows > Task Scheduler.
Right-click the Idle Maintenance task.
Click Disable.
Disable the Regular Maintenance task as well and restart the computer.

source: http://www.tomshardware.com/faq/id-2120194/enable-disable-automatic-maintenance-windows.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.