I'm running a webapp via tomcat on my virtual machine (development environment). I'm trying to access this webapp on other computers (other machines on the network, and the host machine) but I am failing at doing so.

Host: Windows 8.1

Guest: Windows 7

Software: VMWare Player

Guest is set up in bridged mode for the connection, windows firewall is turned off completely.

I can access the webapp via localhost:8080/webapp as well as topaz:8080/webapp (the vm name is topaz) on the VM, but not through the host machine or anywhere else on the network.

Attempting to connect to the webapp via VM's.ip.##.##:8080/webapp from the host machine doesn't work, either. On this note, the VM's IP as reported through ipconfig is different from the one reported by google for my public IP. I am on an internal network, however. It's worth noting that any devices that I need to connect to this webapp will be on my internal network.

If I browse the network via windows explorer on the host machine I am able to SEE the VM, but I'm unable to connect to it

Not sure what else to change, any help is appreciated

Edit: In response to comment below from harrymc,

Changed bridged to NAT. Still can't access machine on network, shared folders still working. In the vm both localhost:8080/webapp and topaz:8080/webapp work. Still can't connect via host or other machine. IP reported by ipconfig starts with 192, ip as reported by google starts with 205.

Switched back to bridged, ipconfig reports an IP starting with 172. Google reports the same 205 IP from when it was in NAT. Same status as before.

Uninstalled VMware tools, rebooted, reinstalled using option 'complete'. Tried again with bridged. No success.

Edit 2: Uninstalled VMWare player, installed workstation, still no luck

  • Can you ping the VM? Can you access shared folders on the VM? What web server are you using? Are you sure it's configured to answer calls from outside the machine? Do you have a firewall enabled? – Ƭᴇcʜιᴇ007 Jul 15 '14 at 16:48
  • Host unreachable when I attempt to ping. I can access shared folders. I'm using tomcat 6. Definitely is configured. Firewall is enabled on host machine, but not VM. Additionally, my IP in ipconfig differs completely from my public ip at whatismyip.com – Mitch Jul 15 '14 at 16:57
  • 1
    Sometimes toggling the VM from Bridged to NAT helps, and if not, then sometimes switching back to Bridged helps. Reboot the VM every time and check ipconfig. You could also reinstall VMware Tools. – harrymc Jul 17 '14 at 15:28
  • @harrymc , updated the OP – Mitch Jul 17 '14 at 16:05
  • Once I solved such a problem by downloading the trial version of VMware Workstation and doing the Bridged/NAT dance. I think the Workstation installation is more complete, but unfortunately that's a one-time solution if you don't buy it, and the problem can come back. So try first reinstalling VMware Player. – harrymc Jul 17 '14 at 16:10

Too many suggestions, so here it is as an answer:

Using VMware Workstation, do in the guest :

  1. Reinstall VMware Tools
  2. Try setting the adapter to a static IP address in the correct range
  3. Remove VM > Settings > Network Adapter and recreate
  4. Add a second Network Adapter
  5. Use Windows Update to patch fully the VM including optional updates (except Bing)
  6. Reinstall the network driver in Windows Device Manager: Find the Intel Pro/1000 MT Network Connection device and try "Update Driver Software" with "Let me pick from a list of device drivers on my computer"
  7. In Device Manager, delete the Intel(R) PRO/1000 MT Network Connection device and reboot
  8. Reset TCP/IP by using in a Command Prompt (cmd) that's Run as Administrator:
    netsh int ip reset c:\resetlog.txt
    Reset Winsock settings by entering
    netsh winsock reset.

Reboot after each step and test ipconfig again.
As a last-ditch effort, you could try again VMWare Player.

Better take a backup of the VM before starting, just in case.

And if nothing works, my only advice left is to get in touch with VMWare Support or in the VMWare forums.

  • I will try the rest of the options I haven't tried, as I'd prefer to use VMWare, but it's worth noting that booting up the machine in VirtualBox (and installing additions) made it work like a charm – Mitch Jul 18 '14 at 14:02
  • Sometimes with VMware nothing works without explanation. You could try previous versions or wait for fixes. Or use VirtualBox ... – harrymc Jul 19 '14 at 17:24

Chances are good that you're dealing with a network limitation of VMware Player. Specifically, the ability to edit network settings. This is a feature in Workstation but not in Player (what do you expect for free? ;-) Check out this feature comparison between Player 6 and Workstation 10.

I think you should download an eval of Workstation and test. Or if you're not bound to VMware, try Microsoft VirtualPC or VirtualBox. They should be able to read your VMDK and are free.

  • I'm currently using the eval of Workstation, and it's not working either. It has previously worked on VirtualBox, but it had its own set of problems – Mitch Jul 18 '14 at 12:44

Install a proxy server on the machine hosting the webapp and connect to that proxy from your other devices. Your devices are able to resolve the hostname on the computer, even though it’s defined in the computer’s local hosts file, because it uses the proxy for DNS resolution.

  • 1
    He doesn't need a proxy server just to access a web server on his LAN. – Ƭᴇcʜιᴇ007 Jul 15 '14 at 16:49

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.