6

I'm trying to launch RSSOwl ( Version: 2.2.1 / Build Id: 2013-12-30 ) on my Ubuntu ( 64 Bit ). Twice, I'm download latest RSSOwl from here http://www.rssowl.org/download

There is such error:

RSSOwl was unable to create a browser for reading news. 
Please refer to the FAQ for further help.

Click 'Ok' to open the FAQ now.

According to FAQ: http://www.rssowl.org/help#item_6j

Download XULRunner 1.9 Runtime
Extract it to any directory that RSSOwl can read
Add a new startup property to rssowl named 
    -Dorg.eclipse.swt.browser.XULRunnerPath=[XULRunner Runtime Directory]
Start RSSOwl and it will pick up the browser from the provided location

I can't understand this point: Start RSSOwl and it will pick up the browser from the provided location

I've extract tgz of XULRunner to /usr/src:

Now, I'm launch RSSOwl in next manner:

./RSSOwl -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/src/xulrunner/xulrunner/

And nothing works...

I'm also trying to select browser directly /usr/lib/firefox/firefox in the settings ( Edit -> Preferences ), too wrong.

Use the embedded browser - too wrong. The same error.

11

I found solution here:

For my installation it looks like:

sudo ln -fs /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 \
/usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0
1
  • Ubuntu18: sudo ln -fs /usr/lib/x86_64-linux-gnu/libhunspell-1.6.so.0.0.1 /usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0. Basically one has to find the latest libhunspell on the system and create a symlink that refers to libhunspell-1.2.so.0. Ensure that the symlink really exists.
    – 030
    Dec 8 '19 at 11:16
7

I found a more profound/prescribed - but in core of course the same - manual to his problem here: http://whilesurfing.blogspot.de/2012/06/make-rssowl-work-with-mint-13-maya.html

Sadly, the author of RSSOwl himself did not come up yet with a new patched version to get rid for good of this hassle. Even long time users changed to other, less functional software, because of it. It's really a shame.

0
0

Ubuntu 16

(Maybe works for other versions)

  1. Create link

    sudo ln -fs /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0
    
  2. Restart RSSOwl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.