3

I have installed Windows 7 64-bit and I get an untrusted certificate error when visiting any website served via SSL, like Google.com, Gmail.com, etc.

I tried this using Firefox, IE and Chrome and it happens in all three! I installed all updates, but that didn't fix the problem.

I reinstalled Windows again and without installing any program or driver, tried to visit SSL sites, but the problem still exists!

Note that when I install Windows 7 32-bit, I don't get any error and everything works! and my windows date/time is correct.

Did anyone have a problem like that?

1
  • 2
    I know you've said this but: Make sure your computer time zone is set for your locale. Check your date and time to the minute using an online resource for your city/country. The computer time being incorrect by even a few minutes will cause this... – Kinnectus Jul 16 '14 at 6:28
4

I've come across a similar issue on a Windows 8 computer. The SSL Roots had been removed somehow.

Installing Microsoft's Root Certificate Update should resolve the issue.

The KnowledgeBase Article can be found here - http://support.microsoft.com/kb/931125

3
  • If it was a SSL Roots problem it wouldn't effect Chrome or Firefox. Chrome handles invalid certificates a little different, and Firefox, uses its entirely own certificate store. There is something else going on. – Ramhound Jul 16 '14 at 2:54
  • Both Chrome and IE use the same store, so if the Root certificate is gone, it will break things. In fact, if the root certificate is gone, Chrome will disallow access to sites that use the SSL root certificate altogether. I'm not sure about Firefox though. – Lawrence Jul 16 '14 at 3:50
  • Except. While Chrome uses the same store, its does not handle invalid certificates in the same way, Firefox uses its own store which is the reason I point out a problem with the root certificate wouldn't effect either one really. But who knows if this actually answered the question. The user didn't provide any comment. – Ramhound Jul 16 '14 at 11:25
3

The problem is the incorrect date and time of the PC, just correct the time (I would sync it).

1
  • 1
    This answer was helpful; syncing from the Control Panel did the trick. – Aaron Blenkush Oct 8 '15 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.