1

I'm trying to install PowerShell 4.0 on a Windows 2008R2 server

Installed Windows6.1-KB2819745-x64-MultiPkg.msu with no errors or warning

But when I run up PowerShell and check the $host.version, it's still 3 0 -1 -1

Compared it to a scratch virtual machine I have with Win2008R2 on, and there version shows as 4 0 -1 -1

And to be double sure, I checked the file version of the powershell.exe

  • Problem server is 6.2.9200.1398
  • Virtual is 6.3.9600.16406
  • It looks like service pack 1 and .Net 4.5 are prerequisites and need to be installed first. A re-boot may be required. (social.technet.microsoft.com/wiki/contents/articles/… ) – CHarmon Jul 16 '14 at 18:46
  • @Charmon Thanks for that ... yeap, the servers are only NET 4.0, whereas my virtual is NET 4.5 Please add as an answer and I'll accept it – SteveC Jul 17 '14 at 11:31
2

It looks like service pack 1 and .Net 4.5 are prerequisites and need to be installed first. A re-boot may be required. (http://social.technet.microsoft.com/wiki/contents/articles/21016.how-to-install-windows-powershell-4-0.aspx)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.