0

WLAN has higher priorities than LAN but Remote Desktop seems to still use WLAN.

I tried to achieve this by setting up a firewall rule but this does not seem to do the trick.

Here is what I tried:

1) Outgoing rule restricting MSTSC.exe to LAN.

  • Interface type selected is LAN
  • Chosen "action": "allow connection"

    In this case RD does not get connection even when I disable WLAN explicitely.

2) Outgoing rule banning MSTSC.exe from WLAN.

  • Interface type selected is WLAN
  • Chosen "action": "block connection"

    In this case RD works when I disable WLAN explicitely.

Common settings:

Both cases refer to only the program: %SystemRoot%\System32\mstsc.exe

Any suggestions what I am doing wrong?

  • Hi again. I believe that you can try c:\windows\system32\mstsc.exe (without asking to expand environment variables) - or whatever the specific path of mstsc is (you can find with where mstsc). – cdavid Jul 17 '14 at 17:31
  • Also a setting you might have to look at is the profile - whether you are on Domain / Private / Public profile for each of the interfaces (WLAN might not be Domain, but LAN is and the rule you created applies only to Domain). – cdavid Jul 17 '14 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.