I'm trying to erase a write-protected USB flash drive. This drive was distributed with Autodesk software on it; the write protection was intentional.

I've tried formatting and deleting, which of course doesn't work; I've tried to set the registry at HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/StorageDevicePolices/WriteProtect to 0 using regedit, which hasn't changed a thing; somebody recommended I change the drive letter, which it won't let me do. Here is the output of Flash Drive Information Extractor:

Volume: E:
Controller: Phison 2303 (2251-03)
Possible Memory Chip(s): 
  Toshiba TH58TEG7DCJBA4C
  Toshiba TC58TEG7DC4JBA4C
Memory Type: MLC
Flash ID: 98DE8493 72D7
Chip F/W: 01.05.10
Firmware Date: 2013-01-18
ID_BLK Ver.:
MP Ver.: MPALL v3.64.0E
VID: 0930
PID: 1400
Manufacturer: TOSHIBA
Query Vendor ID: TOSHIBA
Query Product Revision: PMAP
Physical Disk Capacity: 15846080512 Bytes
Windows Disk Capacity:  12586057216 Bytes
Internal Tags: 2Q2K-S72K
File System: NTFS
USB Version: 3.00
Declared Power: 504 mA
ContMeas ID: 1381-01-00
Microsoft Windows 8 x64
Program Version:

I'm using a Toshiba laptop, so I think that most of the Toshiba info has to do with internal hardware.

Edit: Turns out the drive is made by Toshiba, so the above may not be true.

Does anyone have any ideas for what I should try next? My laptop runs Windows 8.1, but I have access to a XP machine and a Raspberry Pi with Raspbian, if those would be helpful.

Note: I see that there are a lot of similar questions on this site, but I do not think that mine is a duplicate because the write-protection was intentional and the items listed above, many of which came from similar questions, failed.

  • 1
    Do you know how the write protection is implemented? If it's a hardware switch, you can't do anything about it in software. You say it was intentional - then you should know how it happened.
    – Bob
    Jul 17, 2014 at 4:03
  • @Bob: there is no hardware switch, unless it's somehow inside the case. The software company (Autodesk) did it intentionally - I don't know how they did it.
    – Matthew
    Jul 17, 2014 at 4:12
  • 1
    does this answer help?
    – Sathyajith Bhat
    Jul 17, 2014 at 5:32
  • 3
    You should mention that it was provided by Autodesk in your question, as that is significant here.
    – Jason C
    Jul 17, 2014 at 5:43
  • @fixer1234: whoops, retracted the close vote.
    – bwDraco
    Sep 17, 2016 at 6:21

1 Answer 1


There is a very long set of instructions in this forum post -- too long to re-post here (sorry, flaggers) -- which specifically focuses on breaking the write protection on Autodesk-distributed media to repurpose the devices.

Note that it requires a USB 3.0 port, and installation and usage of some low level vendor-specific utilities to disable write protection on the device.

The write protection is vendor-specific and implemented at the controller level. You will not find a physical switch and there is nothing you can do at the file-system / data level to change it.

  • I followed the steps in the blog post for 2014 drives, which is what mine is, but encountered this error on the last step: The system cannot find the path pointed to by report path. I'm not sure what else to do with it. Is there any possibility a utility like killdisk would be able to completely delete it, allowing me to reformat and reuse it?
    – Matthew
    Jul 17, 2014 at 16:05
  • @Matthew No, killdisk would not help. You may wish to ask about the problem you are seeing in that forum, as there are surely folks there with specific knowledge about this situation.
    – Jason C
    Jul 17, 2014 at 16:10
  • 1
    Your link to the instructions broke, do you have a mirror, or can you add the instructions to your post?
    – Ferrybig
    Aug 14, 2019 at 20:37
  • @Ferrybig I'll dig up a replacement today ty for letting me know.
    – Jason C
    Aug 16, 2019 at 11:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .