4

I have a webcam that works fine in software such as camorama and cheese. However, I cannot use it in websites that allow you to use a webcam (it's not recognized).

I tested it with:

  • Chromium 34.0 with Adobe Flash Player 11.2 (64 bits)
  • Chromium 35.0 with Pepper Flash Player (32 bits)
  • Iceweasel 10.0 with Adobe Flash Player 11.2 (64 bits)

Update:

  • Iceweasel 31.7.0 with HTML5 (appear.in) (64 bits)
  • Chromium 43.0 with Pepper Flash

I also tried to use it with avconv and pidgin. Nothing.

As for the microphone, Chromium, some websites (such as appear.in) and Audacity recognize it. Other software such as avconv don't. In summary, it's a f*ing mess. And yes, I selected the same device and "sub device" both with Audacity and avconv and everywhere else. I use ALSA only, however I tried using PulseAudio too.

Websites don't seem to recognize the camera. Neither does Chromium (all versions aforementioned):

enter image description here

Funny thing is, the mic it recognizes is the webcam's microphone!

I'm on Debian 7.6 (wheezy) (Update: 8.0 (jessie)), kernel is x86_64 Linux 3.2.0-4-amd64 but I also tested on a 32 bits computer with the same system. The manufacturer's website says the webcam is supported on Linux. It's a cheap, national webcam (Satellite WB-537).

I also installed Windows XP on a VM and tried to get it working. Skype didn't recognize it (but also recognized the camera's mic!). I downloaded ManyCam but that didn't help.

PS: This is not the issue. I have the website I want under "allow" (without asking). It just doesn't recognize the camera at all.

PPS: Buying a new webcam is an option, but since there's nothing wrong with the current one (as it works on camorama, etc), I'm not sure if it'd solve the issue.

I don't mind using whatever hack/kludge necessary to get it working.

  • Does your webcam work with websites that use html5, rather than flash, to access the camera? Might be worth checking over at Appear.in or Google Hangouts. It's probably best to be 100% certain that it is flash causing the problem (not that I would ever doubt it). – 0xDAFACADE Aug 16 '14 at 17:43
  • @0xDAFACADE It only detects the mic on the camera. I assume it's because, as I mentioned, Chromium itself seems to fail detecting the camera. Nice website btw. PS: I edited the title to not give the idea flash is the issue. – Alex Aug 16 '14 at 21:00
  • I have same issue superuser.com/questions/1290361/… . Did you find a way around ? – JR Utily Jan 30 '18 at 15:59
-1

Is chromium installed as a snap ? If yes, you have to connect the system core camera to the snap one, this is done by:

$ sudo snap connect chromium:camera :camera
  • 1
    I don't understand why this answer was downvoted, it looks like a sensible piece of advice. – gronostaj Feb 9 '18 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.