2

I put in ubuntu in pendrive and made pendrive bootable by unetbootin. Now the pendrive doesn't work anymore due to that, it is not opening, when I put in windows OS, it doesn't show its total space and free space, it says Total Space: 0MB, Free Space 0MB and its not opening.

I tried all possible softwares like SD Formatter, Yumi, PW (partition wizard), windows disk management, etc. but nothing has been successful, tried formatting from CMD too, nothing is able to format it or read it. Please help.

edit: I used gparted and it is unable to detect usb-flash drive. It detects two drives.. one sda1 20gb and other is sda2 200gb, but my USB-Flash Drive is 8GB only. It was not able to detect it and USB port is working fine.

edit#2: On Linux dmesg (without the USB): http://pastebin.com/R8UMMnrD

dmesg (with USB Drive Inserted): http://pastebin.com/ZCnymsUu

Screenshot of gparted: (I can't post more than 2 links, so here is the link which you cannot click, just copy paste in browser) i.imgur.com/72UCk72.png

edit #3: I tried command fdisk in ubuntu:

It says me this:

Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
Building a new DOS disklabel with disk identifier 0x22ea62b2.
Changes will remain in memory only, until you decide to write them.
After that, of course, the previous content won't be recoverable.

Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

Command (m for help): 

edit#4: After running command sudo dd if=/dev/zero of=/dev/sdb i got following:

dd: writing to ‘/dev/sdb’: Input/output error
8193+0 records in
8192+0 records out
4194304 bytes (4.2 MB) copied, 2.57164 s, 1.6 MB/s

Still no solution...

edit #5: I am unable to create partition table. I get this error on all softwares like gparted.

Edit:#6

It says me this: (dmesg after dd) pastebin.com/dq6ACvKc

Then I tried second solution:

sudo mkfs.vfat -c -F32 -I -v /dev/sdb

And I got this error:

mkfs.fat 3.0.26 (2014-03-07)
/dev/sdb has 239 heads and 62 sectors per track,
hidden sectors 0x0000;
logical sector size is 512,
using 0xf8 media descriptor, with 15131636 sectors;
drive number 0x80;
filesystem has 2 32-bit FATs and 8 sectors per cluster.
FAT size is 14749 sectors, and provides 1887763 clusters.
There are 32 reserved sectors.
Volume ID is 6a9b70f8, no volume label.
Searching for bad blocks 4080... mkfs.vfat: bad blocks before data-area: cannot make fs

Looks like no software can help, is there any way that I may reset the pendrive from hardware by physically opening it?

  • 2
    have you tried re-formating it with gparted? – blogger Jul 17 '14 at 17:48
  • 1
    Which filesystem is there on the USB drive? – MariusMatutiae Jul 17 '14 at 17:50
  • There is probably a wonky partition layout on it with non-Windows filesystems. – Steve Jul 17 '14 at 21:22
  • If the drive was given partitions this was to be expected. Windows does not like flash drives with multiple partitions, even multiple NTFS partitions, would cause problems. – Ramhound Jul 18 '14 at 3:03
  • I used gparted now on a linux machine, it doesn't even detect the USB Flash drive. – user1735921 Jul 18 '14 at 13:39
0

Your USB key might be dead if you're getting an I/O error… Look at what dmesg says after trying the dd command again.

Another thing you can try is creating a filesystem on the whole memory (and checking bad sectors with -c):

mkfs.vfat -c -F32 -I -v.
  • Then for me the flash memory is dead, nothing can recover it. – piernov Jul 25 '14 at 14:42
  • I don't think it was caused directly by unetbootin. There are a few factors: a bad-quality flash and a repeated number of writing on the same sectors. unetbootin just overwrote a sector already in a bad state, and it "broke". – piernov Jul 25 '14 at 15:01
  • Ah! I think you are right... that is what happened, I overwrote the ubuntu setup twice using unetbootin without formatting the drive. – user1735921 Jul 30 '14 at 17:19
0

The answer is itself hidden inside the problem creator i.e the software or probably the way your U.S.B was told to boot up your PC .So here it is .. Grab a f copy of Rufus(www.rufus.akeo.ie) another best software to make U.S.B bootable ...but this time you'll use it another way --> So this time we are not booting anything except making U.S.B to do some hardwork. { Believe me I have lost my pen in a similar way many a times in Windows. It is best possible solution before dumping U.S.B into trash...} --> use this program/software to pretend as if you want to boot a OS into machine RUFUS will itself format USB the way he wanted …{ formating and checking of errors on USB might take up to 10 minute or more......just play around this tiny pretty software .......you'll get the result=your healthy USB......}

  • Got the same error which I got in gparted, unable to create partition table. – user1735921 Jul 21 '14 at 10:36
0

Use HP format tool. It run only on windows. Download from here and install. More Information for the HP format Tool here.

Insert the flash to the computer and start the HP Format Tool as shown hereenter image description here

  • did not work, unable to format – user1735921 Jul 21 '14 at 10:35
0

Download Ubuntu as a LiveCD, burn it to a CD or DVD and boot from said disc. However, instead of using Gparted, you could use the built-in "Disk Utility" tool (simply search for it from the Dash menu or gnome-disks in the Terminal).

This is the end-all GUI tool for managing disks plugged into your machine, mounted or otherwise. Under the "Peripheral Devices" section, you should see your flash drive. There you could see exactly how the space on your flash drive is being allocated.

If your flash drive is mounted, unmount it. Using Disk Utility, select and delete any and all partitions for your flash drive under "Volumes". Once this is finished, all there should be is 8GB of free, raw, unpartitioned space.


Don't forget, if there's one or more partitions on the disk that maybe another operating system might not recognize because of the partition format/file system/etc., they may be discounted as non-existent space. I had this happen when a USB boot disk creation went wrong myself.

0

I would find the next as easy to do:

Download Ubuntu iso file, burn it on CD, boot up your machine with this LIVE CD, and then run Gparted. If you have another machine with any Linux then just run Gparted in there. Also Gparted has its own LIVE CD. I believe Gparted is really good, and seriously it goes much far and deeper with disk fixing.

Also, once you have access to Ubuntu machine, you can also create LIVE USB with its original application Startup Disk Creator

enter image description here

  • gparted failed... any other solution ? – user1735921 Jul 18 '14 at 13:42
  • What makes you think it failed? Here at SU is a commonly reciting error messages in posts, or screen shots. Could you please include – Ruslan Gerasimov Jul 18 '14 at 13:45
  • It just didn't detect it... I opened gparted and it showed sda1 and sda2, and none of them is my pendrive actually (not sda1 nor sda2), I am really worried now. No error messages were there. If you see my question I have edited about gparted. – user1735921 Jul 18 '14 at 13:53
  • when you plug this drive what does demsg show? – Ruslan Gerasimov Jul 18 '14 at 14:00
  • Sorry for trouble, I have edited my post, and included all information you have asked. Please see the paste bin links. – user1735921 Jul 18 '14 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.