0

I have 3 monitors hooked up to my computer. OK, technically one is a TV while the other two are monitors. I previously had Windows Vista for a long time and hated it, so I recently switched to Windows 8.1. I never had this issue on Windows Vista but constantly have this issue on Windows 8. The problem I am having is that when I turn on or off the TV the applications constantly switch from Monitor 1 to 2, or the other way around. In other words, Applications move to the opposite screen they were on. The TV would be monitor 3 and they never jump to that monitor, at least not yet. I very rarely use my TV for a monitor, so usually don't move applications to it.

The two monitors are hooked up with typical monitor cables while the TV is hooked up with an HDMI cable. I did specify which monitor is the main one, designated that as monitor 1. I disabled the taskbar from other monitors other than my main one. I did everything that I can think of and the applications continue to switch. Actually what happens is both screens go blank, like they have been shut off, when I turn on or off the TV. Then when the monitors restore the applications have moved to the opposite monitor.

I can give you further details on how I have stuff hooked up, if needed, but I don't think it is necessary. Like I said though, I didn't have this issue on Windows Vista at all and I also didn't change how anything was connected. Does anyone have any suggestions on how to prevent my monitors for going blank and switching applications from one monitor to the next? Windows Vista didn't even cause my monitors to go blank at all.

1

If this is the same as windows 7 then unfortunately microsoft doesn't have an option to give users control over this. So with that, granted this is going to sound unorthodox, it's the fix many use in windows 7. Just cut a thin strip of electrical tape and cover pin 19 on your tv's hdmi cable. This is the pin that tells the computer the display is off. If your monitor doesn't turn on after doing this try going into screen resolution and clicking "detect". Again I know this sounds odd but it's a fix many use if you can't find a different workaround.

enter image description here

  • Thanks for the suggestion. I might have to give this a try. I did find this article to fix the issue sites.google.com/site/ebobster/stuff/displayportblanking. It allows you to set the EDID for each monitor, preventing the issue, however the problem with this solution is I have a GeForce card and the topology option is only for Quadro cards, even though they are all made by NVIDIA. On a side note, after you pointed this out to me I found this exact same pic from other sources saying the tape is on the wrong side, it should be on the left. They had arrows pointing saying wrong and right. – Chris Jul 19 '14 at 0:58
  • I appreciate the input and will give it a try if I can't get anything else to work, then if this does work I will mark it as the answer. If that link doesn't work that I provided, it actually needs an https:// before it. – Chris Jul 19 '14 at 1:02
  • I found the picture you were talking about so added this encase this method does work for you. I found a really long link in the process that I'll share just encase you haven't already seen it. Also I didn't look into the results, but I did a search for NVIDIA inside this document and it had 50 hits. social.technet.microsoft.com/Forums/windows/en-US/… – jAce Jul 21 '14 at 11:57
  • Thanks for the suggestion about the tape, but it doesn't seem to be working. I tried both pins, the left and the right one. When I cover either pin I don't get anything on the TV at all then. It also doesn't recognize that anything is plugged in under screen resolution, even though my monitors still go blank when I plug the HDMI cable in. I also saw that link you added. That was the same link I found earlier showing the picture you changed. It's almost impossible trying to get the electrical tape lined up perfectly with the pin as well, the HDMI slit is so small the tape barely fits. – Chris Jul 30 '14 at 23:17
  • Ugly but lovely. +1 – Hennes Dec 6 '15 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.