8

A couple weeks ago my speakers stopped working. When I reboot, they work perfectly. But eventually some mysterious, and I suspect nefarious, piece of software takes control. (On a related note, Youtube videos seem to stop working when the speakers die). The drivers are up to date, and I ran a Malware Bytes scan and nothing came up.

I first found this question and answer: https://superuser.com/a/496589/79629

In the properties of your audio device, there should be a checkbox option labelled "Allow applications to take exclusive control of this device". IIRC it is enabled by default; disabling it and rebooting should resolve your issue.

At first I thought that worked, but then the speakers stopped working again, even with that option disabled! These two screenshots were taken immediately after each other.

enter image description here

enter image description here

My next thought was to identify what was actually using the speakers. I found this second question and answer: https://superuser.com/a/253751/79629

The Volume Control application, accessible by right-clicking on the volume icon in the notification area next to your clock on the taskbar, or by running sndvol, should identify what applications are presently using your sound card.

However, it only shows me the system sounds.

enter image description here

Side note, Windows 8 has a hilarious tool called "Find and fix audio problems" which literally just checks if you're an idiot and have the volume muted.

  • Do you get the same issue if you perform a clean boot? – and31415 Jul 20 '14 at 11:43
  • @and31415 it's hard to be certain because it always works after reboot and only stops after a time. If I'm using the speakers for music/TV, they work continually. They only stop after ~10 minutes of inactivity. After the clean boot, the speakers are still working after ~1 hr of inactivity, so yes I think this helped. – andrewtweber Jul 21 '14 at 3:27
  • Could be that you've an issue with your audio device being suspended after inactivity. If you still have the issue, check the power settings and disable audio suspend if you can. – piernov Jul 22 '14 at 11:37
  • @piernov could you clarify on where I would change that setting? I don't see any option for audio suspend – andrewtweber Jul 22 '14 at 17:18
  • @andrewtweber - Try this: Change the startup type of Windows Audio service to Disabled, and restart the PC, so suspicious program won't take control of audio device during startup, and after ~20 minutes restart the service. let's see if this helps. – Ĭsααc tիε βöss Jul 24 '14 at 17:34
4
+50

I found that after I updated iTunes to the newest version, I was having the same issue. They installed some push application that was interfering with my sound card. Here is what I did:

Windows key + r Search msconfig Then under services I unchecked all of the Apple manufacturer services Under the startup tab I disabled any Apple products Restarted

My sound has been back up and running since then.

1

Found a solution:

  1. Search the start menu for "Device Manager" and open it
  2. Expand the "Sound, video and game controllers"
  3. Right-click the Audio device and disable it
  4. Right-click and then Enable the Audio device again

Should be working now.

1
  1. for checking device suspension [although it doesnt seem like the problem], go do Device Manager and look for you Sound device, then open it [doubleclick] and look for "Power Management" tab - if it exists. you should also do this for USB hubs , since your sound card might be connected to one of those.

  2. you might have some malware messing about your system. Start with checking task manager, and msconfig.

  3. For some sound cards, you need to make sure to run their proprietary driver software for proper output. Maybe something should load at startup but fails or being terminated by the user [/you].

  4. a good workaround that might work for you, is restarting the Windows audio service. The shortest way of doing that is from an elevated command prompt run: sc stop audiosrv && sc start audiosrv

You should be up and running.

0

I found a simpler solution for the same problem (mine seemed to start occurring following a recent upgrade of my Chrome and Firefox browsers but this may have been coincidence).

Note that this solution has only been tested on a Windows 8.1 system so I am not sure if it will work on other versions of Windows.

  • Step 1: Open up the Search charm (WindowsKey + Q) and type in "View Local Services" then select the gear icon with that name.

Another way this can be opened is from the "Services" tab in Task Manager there is a link at the bottom of the dialog saying "Open Services".

  • Step 2: Scroll down the list towards the bottom and select "Windows Audio Endpoint Builder". In the upper left of the dialog you should see the following text:

Description: Manages audio devices for the Windows Audio service. If this service is stopped, audio devices and effects will not function properly. If this service is disabled, any services that explicitly depend on it will fail to start.

  • Step 3: Just above the Description are two links, "Stop the service" and "Restart the service". Click on Restart. You will get a warning about this affecting other services (in my case they were Windows Audio and DTS APO) which is perfectly normal. Click YES and you will see a series of messages about services being stopped and restarted.

Your sound should now work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.