0

I have external HDD (WD MyBook) and almost every attempt to data, disk is asking for chkdsk. Could it be damaged disk? Or just re-format of disk can be solution? HDD is 3 years old, but not many times used (purchased new).

2
  • Have you actually tried running chkdsk? – Little Helper Jul 18 '14 at 7:22
  • yeah, every time after asking, in cmd: chkdsk letter: /F And this suprise me- this is why I am asking here, if HDD is damaged or re-format could help. – Jerry1 Jul 18 '14 at 7:27
1

It might be marked as dirty

run the following from command line:

fsutil dirty query x:

where x is you drive letter

If it's mark as dirty run chkdsk c: /r

2
  • Not dirty, clean. Maybe I will try to re-format... – Jerry1 Jul 18 '14 at 11:46
  • I tried reformat HDD and also upgrade firmware. But when upgrade firmware from Western Digital, dialog not completed instalation progressbar. So I close the upgrade dialog. Now HDD is detected by Winodws (disk's letter is assaigned), but cannot access to disk and explorer.exe is frozen. There is also problem with disk with boot system... I tried Hirrens boot cd and WD utilites and they cannot see disk. Any ideas? – Jerry1 Aug 14 '14 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.