4

It had been all right all day until a few hours ago when WinSCP suddenly started keeping giving out the hideous "Host is not communicating for more than 15 seconds. Still waiting..." error. I tried to log in via PuTTY as the same user and it worked perfectly.

Sometimes it would successfully log in but it would still quit on the same error over and over again whenever I tried to do something, listing directory, transferring a file, etc. But everything's fine and responsive on PuTTY against the same server and the same user account from the same computer at the same time.

Tried with FileZilla and the exact same problem. If it connects or responds, it's very very slow. Contacted my support and he was never able to replicate the problem.

I'm on Windows and I never manually patched any updates. What could be wrong? My guess is something's wrong with my Windows? But what? Why can PuTTY successfully perform SSH tasks while WinSCP nor Filezilla can't?

Any help would be much appreciated!

5
  • scp or sftp connection? – David Mackintosh Jul 18 '14 at 13:04
  • @DavidMackintosh, it's SFTP. – datasn.io Jul 21 '14 at 3:08
  • Did you try to disable Optimize connection buffer size option in WinSCP? – Martin Prikryl Jul 21 '14 at 6:32
  • Are you able to connect to the server some other way, maybe from another client, and remove files from the directory where you're connecting to? Sometimes if the MTU size is too restrictive (a setting on network devices between your client and the server) this error pops up if there are too many files in the directory; causing your list to be too big to pass through the switches within the 15 second time out. You can also try increasing the allowed timeout period to a higher number. See also official documentation on this error: winscp.net/eng/docs/messagehostisnotcommunicating Let us k – JamesR404 Nov 11 '14 at 16:37
  • @JamesR404, thanks for the detailed help, I'll keep that in mind. The problem mysteriously went away. I have no idea what the problem was and hope I will never need to. – datasn.io Nov 12 '14 at 3:37
1

You can either "Optimize connection buffer size" or increase the "Timeout" for "Server response timeout" in the "Connection" tab in WinSCP to a large number like 2-3 mins. This solved the issue for me.

-2

I came across the same problem recently so I have down-graded my Winscp to 4.3.9. It solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.