9

I have searched all over the internet but cant find any solution. I am using windows 7 and utorrent. Whenever shutdown is given and if there are active downloads , utorrent checks those file on next startup. I have came to the conclusion that somehow utorrent is unable to shutdown, when shutdown command is initiated,hence it gets force closed by win7. How can i mitigate this issue? And for information I am not force shutting down my system, but clicking start-shutdown. Any body??

Torrent version:3.4.2 build 32126 32 bit

bt.graceful_shutdown: false

there is no AutoEndTask key in HKEY_CURRENT_USER\Control Panel\Desktop

5
  • Which uTorrent version and settings are you currently using?
    – and31415
    Jul 19 '14 at 18:20
  • @and31415 I have added version (3.4.2 build 32126 32 bit) which setting should i list, there are nemourous
    – Ratna
    Jul 19 '14 at 19:01
  • I believe uTorrent checks the files for consistency every startup, and that it's a default feature. I'm not sure if you can disable it. Jul 19 '14 at 19:19
  • 2
    @Ratna Yeah, sorry; I meant the Advanced ones, in particular bt.graceful_shutdown. Anyway, consider updating uTorrent to latest version, which is 3.4.2.32354. Also, start regedit.exe and check if there's a registry value called AutoEndTask in the following key: HKEY_CURRENT_USER\Control Panel\Desktop
    – and31415
    Jul 20 '14 at 12:00
  • uTorrent check the files if the files are not in saved in the same directory that has been assigned into it. So, if you have not assigned any default directory to download torrents in, then assign one. However, you can disable file check from the settings bt.magentlink_check_existing_files set it to false.
    – iSR5
    Oct 16 '14 at 11:26
6

Do you have a large number of unfinished downloads? It might be ideal to close utorrent before you shutdown as well. Windows is probably forcing utorrent to close in the middle operations which forces it to check where it left off the next time it's loaded. The way you shut down is irrelevant. Windows force closes applications (sometimes not so gracefully) when you click start -> shut down. It doesn't allow applications to initiate any kind of code that needs to be ran before the app is closed, like utorrent making sure it knows where all torrents are at % wise before it closes.

1

I also found this problem very irritating and I'm happy to announce that I completely solved it! Now my system waits for uTorrent to close completely and only THEN reboots! You don't have to keep an eye on the Windows Task Manager or any other bulls*t.
Here's the solution, it's very simple and completely automatic.
You need two FREE programs to do this:

NirCmd and AutoHotKey You can download them from here:
http://www.nirsoft.net/utils/nircmd.html
http://www.autohotkey.com/

Step 1
Install AutoHotKey

Step 2
Unrar (extract) NirCmd to D:\nircmd (this is important! If you put it elsewhere, the trick won't work)

Step 3
- Go to D:\nircmd
- Create a New Text Document here.
- Paste exacty this text into it:
nircmd.exe waitprocess utorrent.exe exitwin reboot

-Close and save the txt file
- Rename this txt file to "reboot.bat" (YES, rename the extension too!)

Step 4
- Go to D:\nircmd
- Create a New Text Document here again (YES, another one)
- Paste this text into it:
Run C:\Windows\System32\taskkill.exe -im utorrent.exe
Run D:\nircmd\Reboot.bat

-Close and save the txt file
- Rename this txt file to "reboot.ahk" (YES, rename the extension too!)

Step 5
- Copy this newly created "reboot.ahk"
- Go anywhere (for example Desktop) and Right Click, then choose "Paste Shortcut".

Whenever you click that shortcut, your Windows will reboot AFTER it waits for uTorrent to completely close! When Windows starts and you start uTorrent, it WILL NOT re-check! Tested on Windows 8.1 64bit.
Works 100%!

WARNING!
- You have to install AutoHotkey, otherwise the created ahk won't work.
- You HAVE to create both files (reboot.bat and reboot.ahk) in the SAME folder where you extracted nircmd to!

0

Had the same problem.

Using a SOCKS5 VPN. If I added torrents remotely or shut down in the middle it would not "see" where the existing torrents were.

I set bt.magnetlink_check_existing_files to false as recommended.

Worked like a charm.

0

OS Win 7 64-bit Suggestion, make sure you shut down Utorrent before rebooting. Every time I shut down the computer when uTorrent is still running, when I restart uTorrent, every single file does a "recheck" and to my anguish, downloads all the files within the torrent folder I marked as "Skip". Never used to do this, and so far haven't found any other solution.

0
0

go to advanced|search for bt.magnetlink_check_existing_files and set it to false

2
  • 1
    How is this better than other answers?
    – Toto
    Apr 29 '18 at 16:13
  • @C0deDaedalus comments are for improving or clarifying the question, not answers. Answers in comments should be posted as actual answers instead so they can be moderated by the community.
    – bertieb
    Apr 29 '18 at 17:20
-1

You need to set bt.graceful_shutdown: to true

From µTorrent user manual:

bt.graceful_shutdown: If enabled, µTorrent will take as long as it needs to finish its shutdown sequence (writing in-progress pieces to disk, deleting files in deletion queue, and waiting for tracker replies to stop messages -- among other things). That means that even if it takes several minutes to shutdown gracefully, it will wait for that long, and the process will remain in memory until then. If disabled, µTorrent will limit how long it waits to to 10 seconds, and regardless of the state of the shutdown sequence, µTorrent will force itself to exit.

2
  • 5
    Mine is set to true but I keep having the same issue. I guess @Codezilla's answer is probably my case!
    – magusd
    Oct 9 '15 at 11:39
  • This option is enabled by default, but it's still not helping with this issue. May 7 '19 at 17:44
-1

Here's what I do and you don't have to go into advanced preferences. Simply pause your downloads and don't use the shutdown feature, use the hibernate feature instead. This way Windows resumes even if after the pc powers down and you switch off the power on your power strip Windows resumes on the next power up and remembers where you left off without rechecking those huge files. Better yet resuming Windows is faster than waiting for all those files to load all over again. Hope it works for everyone, it's been a big time saver for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.