I used Clonezilla to back up the image of a disk on a Dell Inspiron PC on which I had installed Debian 7.0. I saved the images to a 2 TB Western Digital MyBook. Everything appeared to work fine. Now I would like to restore the disk. I follow the instructions here but, after choosing "Beginner Mode", I get to the screen where I should be able to choose "Restore Disk" but the only options are:

Save disk
Save parts

I can see the WD MyBook when I am running Clonezilla and I choose that as the source of the image. I also followed the solution posted here and set up the directory structure on the MyBook as follows.


2014-06-09-00-imgAppServer contains the clonezilla-img list file. It doesn't matter whether I choose the top directory of the MyBook or I choose /CloneZillaBackup/, I only get the 3 options listed above. I never get the option to "Restore Disk".

  • 1
    Did it actually create an image file on your backup disk? You should have a large .gz file that is the image taken... I'm guessing that if it can't find any images then it won't offer the option to restore... – Kinnectus Jul 20 '14 at 16:59
  • There are .gz files in 2014-06-09-00-imgAppServer. I am currently looking at the files on a Windows system and it includes files with names like sda1.ext4-ptcl-img.gz.aa and sda1.ext4-ptcl-img.gz.ab. Thanks, – OtagoHarbour Jul 20 '14 at 17:03
  • I don't think it created all the necessary files so that's why it's not offering the restore. Ref.: mail-archive.com/clonezilla-live@lists.sourceforge.net/… – Kinnectus Jul 20 '14 at 17:30
  • Thank you for your comments. It inspired me to make the directory, containing the files, accessible so that I could choose it directly. I thus solved a problem in about half an hour after wrestling with it unsuccessfully for several. – OtagoHarbour Jul 20 '14 at 17:44

OK. It appears I have solved the problem. It seems that Clonezilla doesn't like too many subdirectories. I moved 2014-06-09-00-imgAppServer up to the same level as AppServerCloneZilla. That is


Now I have the restore option.

  • +1 Good to know as the docs don't say this could be a problem. – Kinnectus Jul 20 '14 at 18:00

After creating the image I had changed the directory name to something I liked. But then clonezilla did not recognize the directory as image. So I changed the name so that it end with -img (to make it look like original one) and supplied the parent directory as image source. That helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.